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About SolarWinds 
SolarWinds, Inc develops and markets an array of network management, monitoring, and 
discovery tools to meet the diverse requirements of today’s network management and consulting 
professionals. SolarWinds products continue to set benchmarks for quality and performance and 
have positioned the company as the leader in network management and discovery technology. 
The SolarWinds customer base includes over 45 percent of the Fortune 500 and customers from 
over 90 countries. Our global business partner distributor network exceeds 100 distributors and 
resellers. 

Contacting SolarWinds 
You can contact SolarWinds in a number of ways, including the following: 

Team Contact Information 

Sales 

sales@solarwinds.com 
www.solarwinds.com 
1.866.530.8100 
+353.21.5002900 

Technical Support www.solarwinds.com/support  
User Forums http://www.thwack.com/ 

 

Conventions 
The documentation uses consistent conventions to help you identify items throughout the printed 
and online library. 

Convention Specifying 
Bold Window items, including buttons and fields. 
Italics Book and CD titles, variable names, new terms 

Fixed font File and directory names, commands and code examples, 
text typed by you 

Straight brackets, as in 
[value] Optional command parameters 

Curly braces, as in 
{value} Required command parameters 

Logical OR, as in 
value1|value2 

Exclusive command parameters where only one of the 
options can be specified 

 

http://www.solarwinds.net/
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SolarWinds Orion Network Performance Monitor 
Documentation Library 
The following documents are included in the SolarWinds Orion Network Performance Monitor 
documentation library: 

Document Purpose 

Administrator Guide Provides detailed setup, configuration, and 
conceptual information. 

Evaluation Guide 
Provides an introduction to Orion Network 
Performance Monitor features and instructions for 
installation and initial configuration. 

Page Help Provides help for every window in the Orion 
Network Performance Monitor user interface 

Quick Start Guide 
Provides installation, setup, and common scenarios 
for which Orion Network Performance Monitor 
provides a simple, yet powerful, solution. 

Release Notes 
Provides late-breaking information, known issues, 
and updates. The latest Release Notes can be 
found at www.solarwinds.com.  

 
 
 
 
 
 
 
 
 
 
 

http://www.solarwinds.net/
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Chapter 1 

Introduction 

Orion Network Performance Monitor (Orion NPM) delivers comprehensive fault 
and network performance management that scales with rapid network growth 
and expands with your network monitoring needs, allowing you to collect and 
view availability and realtime and historical statistics directly from your web 
browser. While monitoring, collecting, and analyzing data from routers, switches, 
firewalls, servers, and any other SNMP-enabled devices, Orion NPM 
successfully offers you a simple-to-use, scalable network monitoring solution for 
IT professionals juggling any size network. Users find that it does not take a team 
of consultants and months of unpleasant surprises to get Orion NPM up and 
running because the Orion NPM experience is far more intuitive than 
conventional, complex enterprise network management systems. Because it can 
take less than an hour to deploy and no consultants are needed, Orion NPM 
provides quick and cost-effective visibility into the health of network devices, 
servers, and applications on your network, ensuring that you have the realtime 
information you need to keep your systems running at peak performance. 

Why Install SolarWinds Orion NPM 
Out of the box, Orion NPM monitors the following critical performance metrics for 
devices on your network: 

• Network availability 

• Bandwidth capacity utilization 

• Buffer usage and errors 

• CPU and memory utilization 

• Interface errors and discards 

• Network latency 

• Node, interface, and volume status 

• Volume usage 

These monitoring capabilities, along with a fully customizable web-based 
interface, alerting, reporting engines, and flexible expansion capabilities, make 
SolarWinds Orion Network Performance Monitor the easiest choice you will make 
involving your network performance monitoring needs. 
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Benefits of Orion Network Performance Monitor 
Consider the following benefits of Orion Network Performance Monitor. 

Out-of-the-box Productivity 

Automatic discovery and wizard-driven configuration offer an immediate 
return on your investment. Within minutes of installing Orion NPM, you can 
be monitoring your critical network devices. 

Easy to Understand and Use 

Orion NPM is designed for daily use by staff that also have other 
responsibilities. The Orion NPM interface provides what you need where you 
expect to find it and offers advanced capabilities with minimal configuration 
overhead. 

Affordable Value 

While Orion NPM provides functionality that is comparable, if not superior, to 
most other solutions, the cost and maintenance of your Orion NPM 
installation is less than the initial cost of most other solutions. 

Scalability 

By adding individual polling engines, you can scale your Orion NPM 
installation to any environment size. By sharing the same database, you can 
also share a unified user interface, making the addition of polling engines 
transparent to your staff. 

Thwack.com Online Community 

Thwack.com is a community site that SolarWinds developed to provide 
SolarWinds users and the broader networking community with useful 
information, tools and valuable resources related to SolarWinds network 
management solutions. Resources that allow you both to see recent posts 
and to search all posts are available from the Orion Web Console, providing 
direct access to the Thwack.com community. 

Key Features of Orion Network Performance Monitor 
Considering the previously listed benefits of Orion NPM and the following 
features, Orion NPM is a simple choice to make. 

Customizable and Flexible Orion Web Console 

You can easily customize the web console to meet your individual needs. If 
you want to segregate use, you can custom design views of your data and 
assign them to individual users. You can also create web console accounts 
for departments, geographic areas, or any other user-defined criteria. 



SolarWinds Orion Network Performance Monitor  Quick Start Guide 
 

 
Introduction  3 

Automatic Device Discovery 

Wizard-driven device discovery further simplifies the addition of devices and 
interfaces to Orion NPM. Answer a few general questions about your 
devices, and the discovery application takes over, populating Orion NPM and 
immediately beginning network analysis. 

Intuitive Orion NPM Administration 

Using the award-winning, intuitive Orion NPM web interface, you can now 
conduct administrative tasks, such as adding new devices, both individually 
and in groups, establish unique user accounts, and customize web console 
displays from anywhere on your network. These administration features allow 
you to save time by administering Orion NPM tasks remotely without having 
to RDP directly into the Orion NPM host server. 

Open Integration 

Enterprise-tested standards, including a Microsoft® SQL Server database 
and industry-standard MIBs and protocols, are the backbone of the Orion 
NPM network monitoring solution. 

Integrated Wireless Poller 

An integrated wireless device poller enables you to leverage proven Orion 
NPM alerts, reports, and web console resources as you monitor and manage 
wireless thin and autonomous access points in the same views in which you 
are already monitoring your wired network devices.  

Cisco EnergyWise Monitoring 

Cisco EnergyWise technology allows you to responsibly manage energy 
usage across the enterprise. With Orion NPM, you can view EnergyWise 
device management data to measure, report, and reduce the energy 
consumption of any devices connected to EnergyWise-enabled switches. 

Network Atlas 

Network Atlas, the Orion network mapping application, gives you the ability to 
create multi-layered, fully customizable, web-based maps of your network to 
visually track the performance of any device in any location across your 
network in real time. 

Unpluggable Port Mode 

Orion NPM enables you to designate selected ports as unpluggable, so you 
no longer receive unnecessary alerts when users undock or shutdown 
connected devices. This feature is particularly useful for differentiating lower 
priority ports connected to laptops and PCs from more critically important 
infrastructure ports. 
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 Universal Device Pollers 

The Universal Device Poller allows you to easily add any SNMP-enabled 
device into the local monitoring database and collect any statistics or 
information that are referenced in device MIB tables. Using available poller 
transforms in Universal Device Poller Wizard, you can also manipulate data 
collected from multiple Universal Device Pollers to create your own custom 
statistics and then choose your own customized data display. 

VMware ESX Server Monitoring 

Orion NPM gives enables you to monitor VMware ESX servers and any 
virtual machines (VMs) hosted by ESX servers on your network. Available 
resources include lists of VMs on selected ESX servers, performance details 
for ESX servers and hosted VMs, and relevant charts and reports.  

Incident Alerting 

You can configure custom alerts to respond to hundreds of possible network 
scenarios, including multiple condition checks. Orion NPM alerts help you 
recognize issues before your network users experience productivity hits. 
Alert delivery methods and responses include email, paging, SNMP traps, 
text-to-speech, Syslog messaging, and external application execution. 

Integrated Trap and Syslog Servers 

Orion NPM allows you to save time when investigating network issues by 
giving you the ability to use traps and Syslog messages to access network 
information from a single interface instead of requiring that you poll multiplie 
machines. You can use Orion NPM to easily set up alerts and then receive, 
process, forward, and send syslog and trap messages. 

Detailed Historical Reports 

Easily configure reports of data from the Orion database over custom time 
periods. Data is presented in an easily reviewed format in the web console or 
in the Orion Report Writer application. With over 40 built-in reports available, 
you can project future trends and capacity needs, and immediately access 
availability, performance, and utilization statistics. You can also download 
new reports for import into Report Writer from www.thwack.com. 

Extensible Orion NPM Modules 

With additional modules, including Application Performance Monitor, NetFlow 
Traffic Analyzer, VoIP Monitor, IP Address Manager, and the Network 
Configuration Manager integration, Orion NPM can monitor network 
applications, analyze network traffic, analyze VoIP traffic, manage IP address 
and subnet allocations, and monitor EnergyWise devices, respectively. Orion 
modules save time by leveraging the existing Orion NPM deployment to add 
feature functionality without requiring additional standalone software. 
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How Orion Network Performance Monitor Works 
Through ICMP, SNMP, and Syslog communication and data collection, Orion 
NPM can continuously monitor the health and performance of your network. 
Orion NPM does this without installing agents on your mission-critical servers, 
without employing services that take vital resources from critical applications, and 
without opening security holes by installing unmanaged or outdated code. You 
can automate the initial discovery of your network, and then simply add new 
devices to Orion NPM as you add them to your network. Orion NPM stores 
gathered information in a SQL database and provides a user-friendly, highly 
customizable web console in which to view current and historical network status. 

The following diagram provides an overview of the current Orion NPM 
architecture, including interactions among Orion NPM components, the Orion 
NPM database, and the managed nodes on your network. 
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Networking Concepts and Terminology 
The following sections define the networking concepts and terminology that are 
used within Orion NPM. 

Internet Control Message Protocol (ICMP) 
Orion NPM uses the Internet Control Message Protocol (ICMP) to poll for status 
using ping and echo requests of managed devices. When Orion NPM polls a 
managed device using ICMP, if the device is operationally up, it returns a 
response time and record of any dropped packets. This information is used by 
Orion NPM to monitor status and measure average response time and packet 
loss percentage for managed devices. 

Note: Orion NPM only uses ICMP to poll devices for status, average response 
time, and packet loss percentage. Other information displayed in the Orion Web 
Console is obtained using SNMP requests. 

Management Information Base (MIB) 
A Management Information Base (MIB) is the formal description of a set of 
objects that can be managed using SNMP. MIB-I refers to the initial MIB 
definition, and MIB-II refers to the current definition. Each MIB object stores a 
value such as sysUpTime, bandwidth utilization, or sysContact. During 
polling, Orion NPM sends a SNMP GET request to each network device to poll the 
specified MIB objects. Received responses are then recorded in the Orion NPM 
database for use in Orion NPM, including within Orion Web Console resources. 

Most network devices can support several different types of MIBs. While most 
devices support the standard MIB-II MIBs, they may also support any of a 
number of additional MIBs that you may want to monitor. Using a fully 
customizable Orion Universal Device Poller, you can gather information from 
virtually any MIB on any network device to which you have access. 

Simple Network Management Protocol (SNMP) 
For most network monitoring and management tasks, Orion NPM uses the 
Simple Network Management Protocol (SNMP). SNMP-enabled network 
devices—including routers, switches, and PCs—host SNMP agents that maintain 
a virtual database of system status and performance information that is tied to 
specific Object Identifiers (OIDs). This virtual database is referred to as a 
Management Information Base (MIB), and Orion NPM uses MIB OIDs as 
references to retrieve specific data about a selected, SNMP-enabled, managed 
device. Access to MIB data may be secured either with SNMP Community 
Strings, as provided with SNMPv1 and SNMPv2c, or with optional SNMP 
credentials, as provided with SNMPv3. 



SolarWinds Orion Network Performance Monitor  Quick Start Guide 
 

 
Introduction  7 

For more information about MIBs, see “Management Information Base (MIB)” on 
page 6. For more information about SNMP credentials, see “SNMP Credentials” 
on page 7. 

Note: To properly manage devices on your network, you must enable SNMP on 
all devices that are capable of SNMP communications. The steps to enable 
SNMP differ by device, so you may need to consult the documentation provided 
by your device vendor. 

SNMP Credentials 
SNMP credentials secure access to SNMP-enabled managed devices. SNMPv1 
and SNMPv2c credentials serve as a type of password that is authenticated by 
confirming a match between a cleartext SNMP Community String provided by an 
SNMP request and the SNMP Community String stored as a MIB object on an 
SNMP-enabled, managed device. SNMPv3 provides a more secure interaction 
by employing the following fields: 

• The User Name is a required cleartext string that indentifies the agent or poll 
request that is attempting to access an SNMP-enabled device. User Name 
functions similarly to the SNMP Community String of SNMP v1 and v2c. 

• The Context is an optional identifying field that can provide an additional 
layer of organization and security to the information available in the MIB of an 
SNMP-enabled device. Typically, the context is an empty string unless it is 
specifically configured on an SNMP-enabled device. 

• SNMPv3 provides two optional Authentication Methods: Message Digest 5 
(MD5) and Secure Hash Algorithm 1 (SHA1). Both methods, MD5 and SHA1, 
include the Authentication Key with the SNMPv3 packet and then generate 
a digest of an entire SNMPv3 packet that is then sent. MD5 digests are 20 
bytes long, and SHA1 digests are 16 bytes long. When the packet is 
received, the User Name is used to recreate a packet digest using the 
appropriate method. Both digests are then compared to authenticate.  

• SNMPv3 also provides two optional Privacy/Encryption Methods: Data 
Encryption Standard (DES56) and Advanced Encryption Standard (AES128) 
using a 128 bit key. DES56 uses a 56 bit key with a 56 bit salt, and AES128 
uses a 128 bit key with a 128 bit salt to encrypt the full SNMP v3 packet. 
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Chapter 2 

Installing SolarWinds Orion Network 
Performance Monitor 

Orion Network Performance Monitor (Orion NPM) provides a simple, wizard-
driven installation process. For an enterprise-class product, system hardware 
and software requirements are nominal. 

Licensing Orion Network Performance Monitor 
Orion NPM can collect data and detailed information from any of your version 3 
or earlier SNMP-enabled devices, including routers, switches, firewalls, and 
servers. Orion NPM is licensed by the largest number of the three following 
object types: 

Interfaces 

Interfaces include switch ports, physical interfaces, virtual interfaces, sub-
interfaces, VLANs, and any other single point of network traffic. 

Nodes 

Nodes include entire devices, for example, routers, switches, virtual and 
physical servers, access points, and modems. 

Volumes 

Volumes are equivalent to the logical drives that you monitor. 

The following list provides the different types of Orion Network Performance 
Monitor licenses that are available: 

• Up to 100 objects (SL100) 

• Up to 250 objects (SL250) 

• Up to 500 objects (SL500) 

• Up to 2000 objects (SL2000) 

• Unlimited objects (SLX) 

Database size increases with the addition of managed objects. Depending on the 
number of objects and the amount of traffic flowing through them, managing 
more than 8,000 objects may require additional polling engines. For more 
information about adding polling engines, see “Using Additional Polling Engines” 
in the SolarWinds Orion Network Performance Monitor Administrator Guide. 
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Requirements 
SolarWinds recommends that Orion NPM is installed on its own server, with the 
Orion database hosted separately, on its own SQL Server. The following sections 
give minimum requirements for the Orion NPM and Orion database servers. 

Orion NPM Server 
The following table lists minimum software requirements for your Orion server. 

Software Requirements 

Operating System 

Windows 2008 Server (32-bit or 64-bit, running in 32-bit mode) 
Windows 2003 Server (32-bit or 64-bit, running in 32-bit mode) R2 
IIS must be installed. SolarWinds recommends that Orion NPM 
administrators have local administrator privileges to ensure full 
functionality of local Orion NPM tools. Accounts limited to use of the 
web console do not require administrator privileges. 
Note: SolarWinds does not support installation of Orion NPM on 
Windows Vista in production environments. 

Web Server 

Microsoft IIS version 6.0 and later. DNS specifications require that 
hostnames be composed of alphanumeric characters (A-Z, 0-9), the 
minus sign (-), and periods (.). Underscore characters (_) are not 
allowed. For more information, see RFC 952. 
Note: SolarWinds neither recommends nor supports the installation of 
Orion NPM on the same server or using the same database server as a 
Research in Motion (RIM) Blackberry server. 

.NET Framework Version 3.5 or later 

SNMP Trap 
Services 

Windows operating system management and monitoring tools 
component 

Web Console 
Browser 

Microsoft Internet Explorer version 6 or later with Active scripting 
Firefox 3.0 or later 

ESX Server Version 3.5, if Orion NPM monitors VMware ESX Servers. 
 

The following hardware requirements are listed by Orion NPM license level. 

Hardware SL100, SL250, or SL500 SL2000 SLX 

CPU Speed 
2.0 GHz 2.4 GHz 3.0 GHz 

Note: Dual processor, dual core is recommended. 

Hard Drive Space 

2 GB 5 GB 20 GB 
Note: The Orion installer needs approximately 1GB on the drive where 
temporary Windows system or user variables are stored. Per Windows 
standards, some common files may need to be installed on the same 
drive as your server operating system. For more information, see 
“Error! Reference source not found.” on page Error! Bookmark not 
defined.. 

Memory 
2 GB 3 GB 3 GB 
Note: RAID 1 is recommended for the hard drive hosting Orion NPM. 

Application Ports TCP port 17777 must be opened for Orion module traffic 
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Orion Database Server (SQL Server) 
The following table lists software and hardware requirements, by license level, for 
your Orion database server. 

Note: Use the following database select statement to check your SQL Server 
version, service pack or release level, and edition: 

select SERVERPROPERTY ('productversion'), SERVERPROPERTY 
('productlevel'), SERVERPROPERTY ('edition') 

Requirements SL100, SL250, or SL500 SL2000 SLX 

SQL Server 
SQL Server 2005 SP1 Express, Standard, or Enterprise 
SQL Server 2008 Express, Standard, or Enterprise 
Note: Either mixed-mode or SQL authentication must be supported. 

CPU Speed 2.0 GHz 2.4 GHz 3.0 GHz 

Hard Drive Space 

2 GB 5 GB 20 GB 

Note: The Orion installer does need approximately 1GB of space on 
the drive where temporary Windows system or user variables are 
stored. In keeping with Windows standards, some common files may 
need to be installed on the same drive as your server operating 
system. For more information, see “Error! Reference source not 
found.” on page Error! Bookmark not defined.. 

Memory 

2 GB 3 GB 4 GB 

Note: Due to intense I/O requirements, RAID 1+0 is strongly 
recommended for the hard drive hosting the SQL Server database. 
RAID 5 is not recommended for the SQL Server hard drive. 

Application Ports TCP port 17777 must be opened for Orion module traffic 
 

The following x86 components must also be installed. If these components are 
not found on the server on which you want to host your Orion database, the 
Orion Configuration Wizard installs the required components: 

• SQL Server System Common Language Runtime (CLR) Types 

• Microsoft SQL Server Native Client 

• Microsoft SQL Server Management Objects 

Notes: 

• If Orion NPM installs SQL Server System CLR Types, a restart of the SQL 
Server service for your Orion database is required. 

• For improved performance, Orion NPM uses secure SQL CLR stored 
procedures for selected, non-business data operations. 

• If you are using SQL Server 2005 SP1 Express Edition on a Windows XP 
operating system, enable Shared Memory, TCP/IP, and Named Pipes. 
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Virtual Machines and Servers 
Orion NPM installations on VMware Virtual Machines and Microsoft Virtual 
Servers are fully supported if the following minimum configuration requirements 
are met for each virtual machine. 

Note: SolarWinds strongly recommends that you maintain your SQL Server 
database on a separate physical server. 

Virtual Machine 
Configuration 

Orion NPM Requirements by License Level 
SL100, SL250, or SL500 SL2000 SLX 

CPU Speed 2.0 GHz 2.4 GHz 3.0 GHz 

Allocated 
Hard Drive Space 

2GB 5GB 20GB 

Note: Due to intense I/O requirements, SQL Server should be 
hosted on a separate physical server configured as RAID 1+0. RAID 
5 is not recommended for the SQL Server hard drive. 

Memory 2GB 3 GB 3 GB 

Network Interface 

Each installation of Orion NPM should have its own, dedicated 
network interface card.  
Note: Since Orion NPM uses SNMP to monitor your network, if you 
are unable to dedicate a network interface card to your Orion NPM 
installation, you may experience gaps in monitoring data due to the 
low priority generally assigned to SNMP traffic. 

Server Sizing 
Orion Network Performance Monitor is capable of monitoring networks of any 
size, ranging from small corporate LANs to large enterprise and service provider 
networks. Most Orion Network Performance Monitor systems perform well on 3.0 
GHz systems with 3 GB of RAM, using default polling engine settings. However, 
when monitoring larger networks, you should give additional consideration to the 
hardware used and the system configuration. 

There are three primary variables affecting scalability. The most important is the 
number of objects you are managing. Systems monitoring more than 1,000 
elements may require tuning to offer optimal performance. The second variable 
to consider is polling frequency. For instance, if you are collecting statistics every 
five minutes instead of the default nine, the system must work harder and system 
requirements will increase. Finally, the number of simultaneous web users 
accessing the system will have a direct impact on the performance of the system. 

When planning your Orion Network Performance Monitor installation, there are 
four main factors to keep in mind with respect to scalability. These four items are 
CPU, memory, number of polling engines, and polling engine settings. For 
minimum hardware recommendations, see “Requirements” on page 10. For more 
information about polling engines, see “Managing Orion NPM Polling Engines” in 
the SolarWinds Orion Network Performance Monitor Administrator Guide. 
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In some situations, it may be advantageous to install Orion Network Performance 
Monitor and SQL Server on different servers. If you experience performance 
problems or you plan to monitor a very large network, you should consider this 
option. Specifically, when monitoring 2000 elements or more, SolarWinds 
recommends installing SQL Server on a separate server. This scenario offers 
several performance advantages, as the Orion Network Performance Monitor 
server does not have to perform any SQL Server processing, and it does not 
have to share resources with SQL Server. 

If you plan to monitor 8000 or more elements, SolarWinds recommends that you 
install additional polling engines on separate servers to help distribute the work 
load. For more information, contact the SolarWinds sales team or visit 
www.solarwinds.com. For more information about configuring additional pollers, 
see “Using Additional Poller Engines” in the SolarWinds Orion Network 
Performance Monitor Administrator Guide. 

Installing Orion Network Performance Monitor 
The following procedure guides you through installing Orion NPM. Ensure that 
the computer on which you install Orion Network Performance Monitor meets or 
exceeds the stated requirements. For more information about hardware and 
software requirements, see “Requirements” on page 10. 

Notes: 

• If you are upgrading from a previous version of Orion Network Performance 
Monitor, see “Upgrading Orion Network Performance Monitor” on page 17. 

• For evaluation purposes only, Orion NPM may be installed on Windows XP 
or Vista. SolarWinds does not, however, support or recommend the 
installation of Orion NPM on Windows XP or Vista in production 
environments. 

• When installing Orion NPM on Windows XP, you must confirm that Shared 
Memory, Named Pipes, and TCP/IP are enabled on remote databases. 

• When installing Orion NPM on Windows Server 2008 or Windows Vista, you 
must disable IPv6 support in Internet Information Services (IIS). 

To install Orion Network Performance Monitor: 

1. Using the local administrator account, log on to the server on which you want 
to install Orion NPM. 

Notes: 

• To avoid permissions issues, do not log on using a domain account. 

• Do not install Orion NPM on a domain controller. 
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• SolarWinds generally recommends that you backup your database 
before performing any upgrade. 

• If you are using more than one polling engine to collect network 
information, ensure that you shut down each of these polling engines 
before continuing. 

2. If you downloaded the product from the SolarWinds website, navigate to 
your download location, and then launch the executable file.  

3. If you received physical media, browse to the executable and launch it. 

4. If you are prompted to install Microsoft .NET Framework 3.5, click 
Install, and then complete the installation, including a reboot, if required. 

Note: Downloading and installing Microsoft .NET Framework 3.5 may take 
up to 20 minutes or more, depending on your existing system configuration. 

5. If the InstallShield Wizard detects that Microsoft Internet Information 
Services (IIS) is not installed, suspend installation, quit setup, and then 
install Internet Information Services as shown in the following steps: 

a. Click Start > Control Panel > Add or Remove Programs. 

b. Click Add/Remove Windows Components. 

c. Check Application Server, and then click Details. 

d. Confirm that Internet Information Services (IIS) is checked, and then 
click Details. 

e. Confirm that World Wide Web Service is checked, and then click 
Details. 

f. Confirm that World Wide Web Service is checked, and then click OK. 

g. Click OK on both the Internet Information Services (IIS) window and the 
Application Server window. 

h. Click Next on the Windows Component Wizard window. 

i. Click Finish when the configuration of required components completes. 

j. Launch the installer again, and then click Next on the Welcome screen. 

6. If the InstallShield Wizard detects that any of the following SQL Server 
components are not already installed, click Install: 

• Microsoft SQL Server System CLR Types 

• Microsoft SQL Server Native Client 

• Microsoft SQL Server Management Objects 

7. Review the Welcome text, and then click Next. 
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8. Accept the terms of the license agreement, and then click Next. 

9. If you want to install Orion NPM in a destination folder other than the 
default location indicated, click Browse, and then select an installation 
folder and click OK. 

10. Click Next. 

11. Confirm the current installation settings, and then click Next on the Start 
Copying Files window. 

12. Provide the appropriate information on the Install Software License Key 
window, and then click Continue. 

Note: You need your customer ID and password to successfully install the 
key.  For more information, see “Software License Key” on page 67. 

13. Click Continue when the license is successfully installed. 

14. Click Finish on the InstallShield Wizard Complete window. 

15. Click Next on the Welcome window of the Configuration Wizard. 

Note: If the Configuration Wizard does not load automatically, click Start > 
All Programs > SolarWinds Orion > Configuration and Auto-Discovery > 
Configuration Wizard. 

16. If you are prompted to stop services, click Yes.  

Note: To ensure that all updates and changes are installed correctly, it is 
imperative that you stop all services. 

17. Specify the SQL Server instance you want to use to store network data, and 
then provide the credentials, if necessary, to log into the selected instance.  

Notes: 

• The selected instance must support mixed-mode or SQL authentication 
with strong passwords. A strong password must meet at least three of 
the following four criteria: 

• Contains at least one uppercase letter and one lowercase letter. 

• Contains at least one number. 

• Contains at least one non-alphanumeric character, e.g., #, %, or ^. 

For more information about authentication with strong passwords, see 
http://msdn.microsoft.com/ms143705.aspx. 

• If you are using SQL Express, specify your instance as (local) and 
use a strong password. For more information about authentication with 
strong passwords, see http://msdn.microsoft.com/ms143705.aspx. Due 

http://msdn.microsoft.com/ms143705.aspx
http://msdn.microsoft.com/ms143705.aspx
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to its inherent limitations, SolarWinds recommends against the use of 
SQL Express in production environments. 

• If you are creating a new database, the user account must be a 
member of the dbcreator server role.  The sysadmin role and the SA 
user account are always members of dbcreator. 

• If you are using an existing database, the user account needs only to 
be in the db_owner database role for the existing database. 

• If you are creating a new SQL account for use with Orion NPM, the 
user account must be a member of the securityadmin server role. 

Note: The sysadmin role and the SA user account are always members 
of securityadmin. 

• If you are using an existing SQL account, the user account needs 
only to be in the db_owner database role for the Orion NPM database. 

18. Click Next. 

19. If you are creating a new database, select Create a new database, 
provide a name for the new database, and then click Next. 

20. If you are using an existing database, select Use an existing database, 
type the database name or select it from the list, and then click Next. 

21. If you want to create a new SQL account for the Orion NPM polling 
engine and web console to use for accessing the database, select 
Create a new account, provide an account name and password, confirm the 
account password, and then click Next. 

22. If you want to use an existing SQL account for the Orion NPM polling 
engine and web console to use for accessing the database, select the 
existing account, provide the appropriate password, and then click Next. 

23. If you need to specify a particular IP Address for the Orion NPM Web 
Console, provide the IP address of the host web server. 

Note: SolarWinds recommends that you retain the default IP address setting 
of All Unassigned, unless your environment requires the designation of a 
specific IP address for your Orion Web Console. 

24. Specify both the port through which you want to access the web console and 
the volume and folder in which you want to install the web console files.  

Note: If you specify any port other than 80, you must include that port in the 
URL used to access the web console. For example, if you specify an IP 
address of 192.168.0.3 and port 8080, the URL used to access the web 
console is http://192.168.0.3:8080. 

25. Click Next. 
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26. If you are prompted to create a new directory, click Yes. 

27. If you are prompted to create a new website, click Yes. 

Note: Choosing to overwrite the existing website will not result in the deletion 
of any custom Orion NPM website settings you may have previously applied. 

28. Confirm that all services you want to install are checked, and then click Next. 

29. Review the final configuration items, and then click Next. 

30. Click Next on the Completing the Orion Configuration Wizard dialog. 

31. Click Finish when the Orion Configuration Wizard completes. 

32. Log in to the Orion Web Console as an administrator. 

Note: By default, you can log in with User Name Admin and no password. 

33. Complete the Network Sonar Wizard. For more information, see “Network 
Discovery Using the Network Sonar Wizard” on page 21. 

Upgrading Orion Network Performance Monitor 
Complete the following procedure when you are upgrading Orion NPM from a 
previous version or upgrading the licensed number of elements you can monitor. 

Notes: 

• SolarWinds recommends that you backup your database before any upgrade 
and then backup your web console configration afterwards. For more 
information about web console configuration backups, see “Managing Orion 
Web Console Configurations” in the SolarWinds Orion Network Performance 
Monitor Administrator Guide. 

• If you currently have Orion NPM 7.X installed, you must first upgrade to 
Orion NPM 7.8.5. After upgrading from Orion NPM 7.8.5 to Orion NPM 8.5.1, 
you can then upgrade to Orion NPM 9.1 SP5 before upgrading to any newer 
Orion NPM versions. 

To upgrade Orion Network Performance Monitor: 

1. If you are using more than one polling engine to collect network 
information, shut down all polling engines before continuing. 

2. Using the local administrator account, log on to the computer on which you 
want to upgrade Orion Network Performance Monitor. 

3. If you downloaded the product from the SolarWinds website, navigate to 
your download location and then launch the executable.  

4. Review the Welcome text, and then click Next. 
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5. Orion Network Performance Monitor automatically detects the previous 
installation. When prompted to upgrade the current installation, click Next. 

Note: All customizations, including web console settings, are preserved. 

6. Accept the terms of the license agreement, and then click Next. 

7. Confirm the current installation settings. 

8. Click Next on the Start Copying Files window. 

9. Provide the appropriate information on the Install Software License Key 
window. 

Note: You need your customer ID and password to successfully install the 
key.  For more information, see “Software License Key” on page 67. 

10. Click Continue. 

11. Click Continue when the license is successfully installed. 

12. Review the Upgrade Reminder. 

13. Click Next. 

14. Click Finish on the InstallShield Wizard Complete window. 

15. Complete the Configuration Wizard. For more information, see “Installing 
Orion Network Performance Monitor” on page 13. 

Note: If the Configuration Wizard does not load automatically, click Start > 
All Programs > SolarWinds Orion > Configuration and Auto-Discovery > 
Configuration Wizard. 

Enabling SNMP Communication 
Because Orion Network Performance Monitor takes advantage of SNMP 
communication for a great deal of the information it collects, ensure that the 
following configurations are completed prior to either adding network devices or 
conducting a Network Discovery: 

• All Windows servers have the SNMP service installed and running, unless 
you only want to monitor up/down status 

• All Linux/Unix servers have an SNMP daemon installed and running, 
forwarding Syslog information. 

• All devices from which you want to collect detailed information have SNMP 
properly configured  
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Maintaining Licenses with License Manager 
SolarWinds License Manager is an easily installed, free utility that gives you the 
ability to migrate Orion licenses from one computer to another without contacting 
SolarWinds Customer Service. The following sections provide procedures for 
installing and using License Manager. 

Installing License Manager 
Install License Manager on the computer from which you are migrating currently 
licensed products. 

Note: You must install License Manager on a computer with the correct time. If 
the time on the computer is even slightly off, in either direction, from Greenwich 
Mean Time (GMT), you can not reset licenses without contacting SolarWinds 
Customer Service. Time zone settings neither affect nor cause this issue. 

To install License Manager: 

1. Click Start > All Programs > SolarWinds > SolarWinds License Manager 
Setup. 

2. Click I Accept to accept the SolarWinds EULA. 

3. If you are prompted to install the SolarWinds License Manager 
application, click Install. 

Using License Manager 
You must run License Manager on the computer where the currently licensed 
SolarWinds product is installed before you can migrate licenses to a new 
installation. The following procedure deactivates currently installed licenses that 
can then be transferred to a new installation. 

To activate currently installed licenses: 

1. Click Start > All Programs > SolarWinds > SolarWinds License Manager. 

2. Check the products you want to deactivate on this computer. 

3. Click Deactivate. 

4. Specify your SolarWinds Customer ID and password when prompted, and 
then click Deactivate. 

Note: Deactivated licenses are now available to activate on a new computer. 

When you have successfully deactivated your products, log on to the computer 
on which you want to install your products, and then begin installation. When 
asked to specify your licenses, provide the appropriate information. The license 
you deactivated earlier is then assigned to the new installation. 
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Chapter 3 

Getting Started with Orion NPM 

Orion Network Performance Monitor (Orion NPM) comprises a number of 
monitoring, alerting, reporting and display tools. The following sections provide 
an introduction to the network monitoring tools that are available in Orion NPM.  

Network Discovery Using the Network Sonar Wizard 
After Orion NPM is installed, the easy-to-use Network Sonar Wizard directs you 
in the discovery of devices on your network. Before using the Network Sonar 
Wizard, consider the following points about network discovery in Orion NPM: 

• Discovery does not add devices that are already in your Orion database. 
Network Sonar safely recognizes and adds only new network devices.  

• CPU and Memory Utilization charts are automatically enabled for your 
Windows, Cisco Systems, VMware, and Foundry Networks devices. 

• The community strings you provide in the Network Sonar Wizard are only 
used for SNMP GET requests, so read-only strings are sufficient. 

The following procedure steps you through the discovery of devices on your 
network using the Network Sonar Wizard. 

To discover devices on your network: 

1. Click Start > All Programs > SolarWinds Orion > Configuration and 
Auto-Discovery > Network Discovery. 

2. If you have already defined a network discovery, select one of the 
following options: 

• If you want to create a new discovery, click Add New Discovery. 

• If you want to use an existing discovery to rediscover your network, 
select the discovery you want to use, click Discover Now, and then 
complete the Network Sonar Results Wizard. For more information, see 
“Using the Network Sonar Results Wizard” on page 25. 

• If you want to edit an existing discovery before using it, select the 
discovery you want to edit, and then click Edit. 

• If you want to view the results of an existing discovery, select the 
discovery you want to view, click View Results, and then complete the 
Network Sonar Results Wizard. For more information, see “Using the 
Network Sonar Results Wizard” on page 25. 
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3. If the devices on your network do not require community strings other 
than the default strings public and private provided by Orion NPM, 
click Next. 

4. If any of your network devices require community strings other than 
public and private or if you want to use an SNMPv3 credential, 
complete the following steps to add the required SNMP credential. 

Note: Repeat the procedure in this step for each new community string you 
need to add. When you have added all your community strings, you can 
highlight them, and then move them up or down in the list by using the 
arrows to the right. To speed up discovery, move the most commonly used 
community strings on your network to the top of the list. 

a. Click Add New Credential. 

b. Select the SNMP Version of your new credential. 

c. If you are adding an SNMPv1 or SNMPv2c credential, provide the 
new SNMP Community String. 

d. If you are adding an SNMPv3 credential, provide the following 
information for the new.credential: 

• User Name 

• Context 

• Authentication Method 

• Authentication Password/Key 

• Privacy/Encryption Method 

• Privacy/Encryption Password/Key 

e. Click Add. 

5. Click Next. 

6. If you want to discover devices located on your network within a 
specific range of IP addresses, complete the following procedure. 

Note: Only one selection method may be used per defined discovery.  

a. Click IP Ranges in the Selection Method menu. 

b. For each IP range, provide both a Start address and an End address. 

c. Click Add to add the defined IP address range. 

Note: Click X to delete an incorrect IP address range. 

d. If you have added all the IP ranges you want to poll, click Next. 
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7. If you want to discover devices connected to a specific seed router or 
located on a specific subnet of your network, complete the following 
procedure: 

Note: Only one selection method may be used per defined discovery.  

a. Click Subnets in the Selection Method menu. 

b. If you want to discover on a specific subnet, click Add a New 
Subnet, provide both a Subnet Address and a Subnet Mask for the 
desired subnet, and then click Add. 

Note: Repeat this step for each additional subnet that you want to poll 
for any new devices. 

c. If you want to discover devices using a seed router, click Add a 
Seed Router, provide the IP address of the Router, and then click Add. 

Notes: 

• Repeat this step for each additional seed router. 

• Orion NPM reads the routing table of the designated router and 
offers to discover devices on the Class A network (255.0.0.0 mask) 
containing the seed router and the Class C networks (255.255.255.0 
mask) containing all interfaces on the seed router, using the SNMP 
version chosen previously on the SNMP Credentials page. 

• Networks connected through the seed router are NOT automatically 
selected for discovery. 

d. Confirm that all networks on which you want to conduct your network 
discovery are checked, and then click Next. 

8. If you already know the IP addresses or hostnames of the devices that 
you want to discover and include in the Orion database, complete the 
following procedure: 

a. Click Bulk Upload in the Selection Method menu. 

b. Type the IP addresses or hostnames of the devices you want Orion NPM 
to discover for monitoring into the provided field. 

Notes: 

• If you are providing IP addresses, only IPv4 addresses are valid. 

• Type only one IPv4 address or hostname per line. 

c. Click Validate to confirm that the provided IP addresses and hostnames 
are assigned to SNMP-enabled devices. 

d. If you have provided all the IP addresses and hostnames that you 
want to discover, click Next. 
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9. Configure the options on the Discovery Settings page as detailed in the 
following steps. 

a. Provide a Name for the current discovery to distinguish it from other 
discovery configurations you may use at other times to discover other 
areas of your network. 

b. Provide a short Description of the current discovery. 

Note: This Description displays next to the Name in the list of available 
network discovery configurations on the Network Discovery view. 

c. Position the slider or type a value, in ms, to set the SNMP Timeout. 

Notes: 

• Typically, you should set the SNMP Timeout to be a little more than 
double the amount of time it takes for a packet to traverse the 
longest route between devices on your network. 

• If you are encountering numerous SNMP timeouts during Network 
Discovery, increase the value for this setting. 

d. Position the slider or type a value, in ms, to set the Search Timeout. 

Note: The Search Timeout is the amount of time Orion NPM waits to 
determine if a given IP address has a network device assigned to it. 

e. Position the slider or type a value to set the number of SNMP Retries. 

Note: This value is the number of times Orion NPM will retry a failed 
SNMP request, defined as any SNMP request that does not receive a 
response within the SNMP Timeout defined above. 

f. Position the slider or type a value to set the Hop Count. 

Note: If the Hop Count is greater than zero, Orion NPM searches for 
devices connected to any discovered device. Each connection to a 
discovered device counts as a hop. 

g. Position the slider or type a value to set the Discovery Timeout. 

Note: The Discovery Timeout is the amount of time, in minutes, Orion 
NPM is allowed to complete a network discovery. If a discovery takes 
longer than the Discovery Timeout, the discovery is terminated. 

10. If you only want to use SNMP to discover devices on your network, 
check Use SNMP only. 

11. Click Discover to start your network discovery. 

Note: Because some devices may serve as both routers and switches, the 
total number of Nodes Discovered may be less than the sum of reported 
Routers Discovered plus reported Switches Discovered. 
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Using the Network Sonar Results Wizard 
Orion NPM provides the straightforward Network Sonar Results Wizard to direct 
you selecting network devices for monitoring. The Network Sonar Results Wizard 
opens whenever discovery results requested, either at the end of the Network 
Sonar Wizard or when View Results is clicked. For more information, see 
“Network Discovery Using the Network Sonar Wizard” on page 21. 

The following steps detail the process of selecting discovered devices, interfaces, 
and volumes for monitoring in Orion NPM. 

To select the results of a network discovery for monitoring in Orion NPM: 

1. On the Device Types to Import page, check the device types you want Orion 
NPM to monitor. 

Note: If you are not sure whether or not you want Orion NPM to monitor a 
specific device type, check the device type in question. If, later, you do not 
want Orion NPM to monitor a device of the selected type, simply delete the 
device using Web Node Management. For more information, see “Managing 
Devices in the Orion Web Console” on page 27. 

2. Click Next. 

3. On the Interface Types to Import page, check the interface types you want 
Orion NPM to monitor. 

Note: If you are not sure whether or not you want Orion NPM to monitor a 
specific interface type, check the interface type in question. If, later, you do 
not want Orion NPM to monitor an interface of the selected type, simply 
delete the interface using Web Node Management. For more information, 
see “Managing Devices in the Orion Web Console” on page 27. 

4. Click Next. 

5. On the Volume Types to Import page, check the volume types you want 
Orion NPM to monitor. 

Note: If you are not sure whether or not you want Orion NPM to monitor a 
specific volume type, check the volume type in question. If, later, you do not 
want Orion NPM to monitor an volume of the selected type, simply delete the 
volume using Web Node Management. For more information, see “Managing 
Devices in the Orion Web Console” on page 27. 

6. Click Next. 

7. Check valid states for imported interfaces, and then click Next. 

Note: By default, Orion NPM imports interfaces that are discovered in an 
Operationally Up state. However, because interfaces may cycle off and on 
intermittently, the Import Settings page allows you to select interfaces found 
in Operationally Down or Shutdown states for import, as well. 
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8. Confirm that all the devices, interfaces, and volumes that you want to import 
are checked in the Import Preview list, and then click Import. 

9. After the import completes, click Finish. 

Note: Imported devices display in the All Nodes resource. 

Configuring the Orion Web Console 
The primary user interface for Orion NPM is the Orion Web Console, where 
performance data for your network devices is most easily viewed. The following 
sections describe the primary administrative functions performed by an Orion 
Web Console administrator. For more information about administrative functions 
in the Orion Web Console, including extensive configuration examples, see 
“Managing the Orion Web Console” in the SolarWinds Orion Network 
Performance Monitor Administrator Guide. 

Logging in for the First Time as an Adminstrator 
The first time that you start the Orion Web Console, you will be presented with a 
login page requiring both a User Name and a Password. Log in to the Orion 
Web Console as shown in the following steps. 

To log in to the Orion Web Console: 

1. Launch the browser on your Orion NPM host server. 

2. Enter http://ip_address or http://hostname where ip_address is the IP 
address of your Orion NPM host server or where hostname is the domain 
name of the server hosting your Orion NPM installation. 

3. Enter Admin as your User Name, and then click Login. 

Note: After your first login, you may want to change the Admin password. 
For more information, see “Changing an Account Password” on page 26. 

Changing an Account Password 
Orion NPM Administrators may change user account passwords at any time, as 
shown in the following procedure. 

To change an account password: 

1. Log in to the web console as an administrator. 

2. Click Admin in the Views toolbar. 

3. Click Account Manager in the Accounts grouping of the Orion Website 
Administration page. 
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4. Select the user account with the password you want to change, and then 
click Change Password. 

5. Complete the New Password and Confirm Password fields, and then click 
Change Password. 

6. Click Continue when the password is successfully changed. 

Managing Devices in the Orion Web Console 
Managing all the monitored devices on your network is greatly simplified with the 
Node Management feature of the Orion Web Console. Using this tool, you can 
easily add and remove nodes, interfaces, and virtual servers and quickly view 
and edit device properties. Any user that has been granted node management 
rights can directly access the Node Management tool either from any All Nodes 
resource or through the Orion Website Administration page. For more information 
about granting node management rights, see “Editing User Accounts” in the 
SolarWinds Orion Network Performance Monitor Administrator Guide. 

The following sections describe the various functions that allow you to view and 
manage all your network devices from the Orion Web Console. 

Note: The Node Management feature is accessible by clicking Manage Nodes 
either in the header of any All Nodes resource or in the Node Management group 
of the Orion Website Administration page. The All Nodes resource is included on 
the Network Summary Home view by default, but you can include it on any other 
web console view as well. Confirm that the All Nodes resource is available on an 
appropriate Web Console view before continuing. For more information about 
adding resources to Orion NPM views, see “Editing Views” in the SolarWinds 
Orion Network Performance Monitor Administrator Guide. 

Adding Devices for Monitoring in the Web Console 
The following procedure details the steps required to add a device and its 
interfaces and volumes for monitoring in the Orion Web Console. 

To add a device for monitoring in the Orion Web Console: 

1. Log in to the Orion Web Console as an administrator. 

2. Click Admin in the Views toolbar. 

3. Click Manage Nodes in the Node Management grouping of the Orion 
Website Administration page. 

4. Click Add Node on the Node Management toolbar. 

5. Provide the hostname or IP Address of the node you want to add in the 
Hostname or IP Address field. 
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6. If you want to add an External node to monitor a hosted application 
with Orion Application Performance Monitor, check External. 

Note: Orion NPM does not collect or monitor any network performance data 
from nodes designated as External. The External status is reserved for 
nodes hosting application that you want to monitor with Orion Application 
Performance Monitor. 

7. If you only want to use ICMP to monitor node status, response time, or 
packet loss for the added node, check ICMP (Ping only). 

8. If you want to use SNMP to monitor the added node, clear ICMP (Ping 
only), and then complete the following steps: 

a. Select the SNMP Version for the added node. 

Note: Orion NPM uses SNMPv2c by default. If the device you are 
adding supports or requires the enhanced security features of SNMPv3, 
select SNMPv3. 

b. If you have installed multiple polling engines, select the Polling 
Engine you want to use to collect statistics from the added node. 

Note: This option may not be available if you are only using one polling 
engine to collect information from your network. 

c. If the SNMP port on the added node is not the Orion NPM default of 
161, provide the actual port number in the SNMP Port field. 

d. If the added node supports 64 bit counters and you want to use 
them, check Allow 64 bit counters. 

Note: Orion NPM fully supports the use of 64-bit counters; however, 
these high capacity counters can exhibit erratic behavior depending on 
manufacturer implementation. If you notice peculiar results when using 
these counters, use the Node Details view to disable the use of 64-bit 
counters for the device and contact the hardware manufacturer. 

9. If you want Orion NPM to use SNMPv2c to monitor the added node, 
provide valid community strings for the added node. 

Note: The Read/Write Community String is optional, but Orion NPM does 
require the public Community String, at minimum, for node monitoring. 

10. If you want Orion NPM to use SNMPv3 to monitor the added node, 
provide the following SNMP Credentials, Authentication, and 
Privacy/Encryption settings: 

• SNMPv3 Username 

• SNMPv3 Context 

• SNMPv3 Authentication Method 
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• SNMPv3 Authentication Password/Key 

• SNMPv3 Privacy/Encryption Method 

• SNMPv3 Privacy/Encryption Password/Key 

11. If you are using SNMP to communicate with your added node, click 
Validate SNMP after entering all required credentials to confirm your SNMP 
settings. 

12. Click Next. 

13. Check the interfaces, volumes, and interface charts for the added node that 
you want Orion NPM to monitor. The following options are available in the 
selection toolbar: 

• Clicking All selects all listed devices and charts for monitoring. 

• Clicking None clears any checked interfaces, volumes, or interface 
charts that have been selected for monitoring. 

• Clicking All Active Interfaces selects only currently active interfaces 
and the associated interface charts for monitoring. 

• Clicking All Volumes selects all listed volumes for monitoring. 

• Clicking All Interfaces selects all listed interfaces for monitoring. 

14. After you have selected interfaces, volumes, or interface charts for 
monitoring, click Next. 

15. If you want to apply pollers to the added node, click + to expand poller 
groups, as necessary, check the appropriate pollers, and then click Next. 

Note: For more information about using predefined pollers or about defining 
your own universal device pollers, see “Monitoring MIBs with Universal 
Device Pollers” in the SolarWinds Orion Network Performance Monitor 
Administrator Guide. 

16. If you want to edit the SNMP settings you provided earlier, change the 
appropriate values in the SNMP area of the Change Properties page, and 
then click Validate SNMP to confirm your new settings. 

17. If you want to edit the default polling settings for your added node, 
change the Node Status Polling or Collect Statistics Every values in the 
Polling area of the Change Properties page, as appropriate. 

Note: The Node Status Polling value refers to the period of time, in 
seconds, between the node status checks performed by Orion NPM on the 
added node. The Collect Statistics Every value refers to the period of time 
between updates Orion NPM makes to displayed statistics for the added 
node. 
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18. If you have defined any custom properties for monitored nodes, provide 
appropriate values for the added node in the Custom Properties area. 

Note: The Custom Properties area is empty if you have not defined any 
custom properties for monitored nodes in Orion NPM. 

19. Click OK, Add Node when you have completed properties configuration. 

20. If you have successfully added the node, click OK on the dialog. 

Deleting Devices from Monitoring 
The following procedure deletes devices from monitoring in the web console. 

Warning: Deleting nodes from monitoring in the web console automatically 
terminates monitoring of all interfaces and volumes on deleted nodes. 

Note: You can select multiple devices to delete at the same time. Additionally, 
using the search tool above the node list, you can select multiple interfaces on 
different nodes for simultaneous deletion.  

To delete devices from monitoring in the Orion Web Console: 

1. Log in to the Orion Web Console as an administrator. 

2. Click Admin in the Views toolbar, and then click Manage Nodes in the Node 
Management grouping of the Orion Website Administration page. 

3. If you want to delete a node, complete the following steps. 

a. Locate the node to delete using either of the following methods: 

• Use the tool above the node list to search the Orion database. 

• Select an appropriate Group by: criterion, and then click the 
appropriate group including the node to delete. 

b. Check the node to delete in the list, and then click Delete on the toolbar. 

4. If you only want to delete an interface or a volume, complete the following 
steps. 

a. Locate the device to delete using any of the following methods: 

• Use the search tool above the node list to search your Orion 
database for the interface you want to delete. 

• Use the search tool above the node list to search your Orion 
database for the parent node of interface or volume to delete. 

• Select an appropriate Group by: criteria, and then click the 
appropriate group including the parent node of the interface or 
volume to delete. 
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b. If you have a list of node results, click + to expand the parent node of 
the interface or volume you want to delete. 

c. Check the interface or volume to delete, and then click Delete on the 
Node Management toolbar. 

5. Click OK to confirm deletion. 

Editing Device Properties 
The following procedure provides the steps required to edit node, interface, or 
volume properties using the Node Management utility of the Orion Web Console. 

To edit device properties in the Orion Web Console: 

1. Log in to the Orion Web Console as an administrator. 

2. Click Admin in the Views toolbar. 

3. Click Manage Nodes in the Node Management grouping of the Orion 
Website Administration page. 

4. Locate the device to edit using either of the following methods: 

• Use the search tool above the node list to search your Orion database 
for either the node or interface you want to edit or the parent node of the 
volume you want to edit. 

• Select an appropriate Group by criteria, and then click the appropriate 
group including either the node to edit or the parent node of the interface 
or volume to edit. 

5. If you want to edit the properties of a monitored node, check the node 
you want to edit, and then click Edit Properties. 

6. If you want to edit the properties of a monitored interface, click + next to 
the parent node of the interface you want to edit, check the interface you 
want to edit,and then click Edit Properties. 

7. Edit the appropriate device properties as needed. 

8. If you are editing the SNMP properties of a node, click Validate SNMP 
after providing new SNMP settings to confirm that they are valid for the 
edited node. 

9. If you have completed your edits, click Submit. 
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Viewing Node Resources 
The List Resources feature of the Orion Web Console Node Management utility 
allows you to immediately see all monitored interfaces, volumes, and interface 
charts on a selected node, as shown in the following procedure. 

To view a list of all resources present on a node: 

1. Log in to the Orion Web Console as an administrator. 

2. Click Admin in the Views toolbar. 

3. Click Manage Nodes in the Node Management grouping of the Orion 
Website Administration page. 

4. Locate the node to view using either of the following methods: 

• Use the search tool above the node list to search your Orion database 
for the node you want to view. 

• Select an appropriate Group by criteria, and then click the appropriate 
group including the node to view. 

5. Check the node you want to view from the list, and then click List 
Resources on the Node Management toolbar. 

Setting Device Management States 
Monitored devices are regularly polled for operational status. Collected statistics 
are displayed in the Orion Web Console. Using the Node Management feature of 
the Orion Web Console, the management status of monitored nodes, is easily set 
or changed, allowing you to either temporarily suspend data collection or resume 
polling and statistics collection, as necessary. The following procedure sets or 
changes management states for monitored nodes in the Orion Web Console. 

Note: Setting a node to an unmanaged state automatically suspends the 
management of all interfaces and volumes on the selected node. 

To set or change the management state of a node: 

1. Log in to the Orion Web Console as an administrator. 

2. Click Admin in the Views toolbar, and then click Manage Nodes in the Node 
Management grouping of the Orion Website Administration page. 

3. Locate the node to manage using either of the following methods: 

• Use the search tool above the node list to search your Orion database 
for the device you want to manage. 

• Select an appropriate Group by criteria, and then click the appropriate 
group including the node to manage. 
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4. Check the node to change, and then click Unmanage or Remanage, as 
appropriate, for the selected node. 

5. If you have selected Unmanage, provide start and end times and dates for 
your management suspension, and then click OK. 

Assigning Pollers to Monitored Devices 
Orion NPM provides both a selection of predefined pollers and the Universal 
Device Poller utility for defining your own pollers to monitor specific aspects of 
your network devices. In the Orion Web Console, the assignment of pollers to 
monitored devices is a straightforward process, as shown in the following steps. 

Note: If you do not see a poller that meets your specific monitoring needs, use 
the Universal Device Poller to create your own poller. For more information, see 
“Monitoring MIBs with Universal Device Pollers” in the SolarWinds Orion Network 
Performance Monitor Administrator Guide. 

To assign a poller to a monitored device: 

1. Log in to the Orion Web Console as an administrator. 

2. Click Admin in the Views toolbar, and then click Manage Nodes in the Node 
Management grouping of the Orion Website Administration page. 

3. Locate the node to poll, the interface to poll, or the parent node of the 
interface or volume to poll using either of the following methods: 

• Use the search tool above the node list to search your Orion database. 

• Select an appropriate Group by criteria, and then click the appropriate 
group including either the node to poll or the parent node of the interface 
or volume to poll. 

4. If you want to assign a poller to a node, complete the following steps: 

a. Check the monitored node to which you want to assign the poller. 

b. Click Assign Pollers in the Node Management toolbar. 

c. Check the pollers you want to assign to the selected node. 

d. Click Submit. 

e. Click OK to confirm the assignment. 

5. If you want to assign a poller to an interface or volume, complete the 
following steps: 

a. Click + next to the parent node of the interface or volume to which you 
want to assign the poller. 

b. Check the interface or volume to which you want to assign the poller. 
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c. Click Assign Pollers in the Node Management toolbar. 

d. Check the pollers you want to assign to the selected interface or volume. 

e. Click Submit. 

f. Click OK to confirm the assignment. 

Adding Views to the Admin Toolbar 
As an example of a useful customization in the Orion Web Console, the following 
procedure adds a Network Trends chart view to the Admin toolbar. 

To add the Network Trends chart view to the Admin toolbar: 

1. Click Start > All Programs > SolarWinds Orion > Orion Web Console. 

2. Log in to the Web Console as an administrator, and then click Admin in the 
Views toolbar. 

3. Click Customize Menu Bars in the Customize grouping of the Orion Website 
Administration page, and then click Edit under the Admin menu bar. 

4. Click and drag Network Trends from the Available items list on the left to the 
Selected items list on the. 

Note: The Edit Admin Menu Bar lists a wide array of views that can be added 
directly to the Orion Web Console Views toolbar. Hover over any view title to 
read a view description. Selected views may be further customized by 
clicking Edit next to the view title. 

Note: Selected items display from left to right in the edited menu bar as they 
are listed from top to bottom. 

5. Click Submit on the Edit Admin Menu Bar page. 

6. Click Network Trends on the Admin toolbar.  

Note: Due to the amount of data queried from the database, the Network 
Trends resources may take a significant time to load. You can also edit the 
number of resources included in the view to reduce the time to load. For 
more information about customizing views, see “Customizing Views” in the 
SolarWinds Orion Network Performance Monitor Administrator Guide. 
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Chapter 4 

Using Orion Network Performance Monitor 

A wealth of information can be collected about your network using the powerful 
tools that comprise Orion Network Performance Monitor (Orion NPM). The first 
two sections in this chapter introduce the configuration of Orion NPM reports and 
alerts. The sections following the alerts and reports introductions describe four 
common use cases for Orion NPM. After completing these quick introductions, 
you will be able to  take advantage of the following core capabilities of Orion 
NPM: 

• Realtime performance charts and gauges. 

• Node response and availability monitoring. 

• Real bandwidth usage measurement. 

• Powerful status and performance reporting. 

The following cases are explored in the order of run time, that is, the amount of 
time you need to have Orion NPM running to see representative results. 

1. Network performance monitoring (results in approximately 1 hour) 

2. Server management (results in approximately 1 hour) 

3. Network availability (meaningful results in approximately 1 week) 

4. Long-term trend analysis (meaningful results in approximately 3 months) 

Note: After installing Orion NPM, the polling engines create a baseline by 
collecting status and statistics immediately, and then collecting them again 30 
seconds later. You may notice an increase in your CPU usage during this time. 
After this initial collection, Orion NPM collects network data every 10 minutes for 
nodes, every 9 minutes for interfaces, and every 15 minutes for volumes.  

Creating Custom Orion NPM Reports 
Orion NPM provides the Report Writer utility for creating custom network 
monitoring reports. A variety of reports are included with Report Writer, and icons 
that precede report names distinguish the different types of reports that are 
available. The following procedure starts Report Writer. 

Note: Before Report Writer can create useful reports Orion NPM must have 
collected at least a few minutes worth of data in the Orion database populated 
with the network devices that you want to monitor. 
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To start Report Writer: 

1. Click Start > All Programs > SolarWinds Orion > Report Writer. 

2. Click File > Settings. 

3. In the General tab of the Report Writer Settings window, select either of the 
following as a default viewing mode: 

• Preview displays the report as it will appear in printed form. For more 
information, see “Preview Mode” on page 36. 

• Report Designer is the report creation and editing interface. For more 
information, see “Design Mode” on page 36. 

Note: You can toggle between Preview and Report Designer modes at any 
time by clicking Preview or Design, respectively, on the toolbar. 

4. If you want to separate the data for individual network objects with 
horizontal lines, click Report Style, and then check Display horizontal 
lines between each row. 

5. Click OK to exit Report Writer Settings.  

Preview Mode 
Preview mode shows a report as it will print. When you open a report in Preview 
mode, or switch to Preview mode from Design mode, Orion NPM runs the query 
to generate the report and Report Writer displays the results. 

The toolbar at the top of the Preview window provides the following actions and 
information: 

• Current page number and total number of pages in the report in the form 
current# / total# 

• Page navigation buttons: First Page, Page Up, Page Down, and Last Page 

• Zoom views 

Note: Double-click on a report preview to zoom in and double-right-click to 
zoom out. 

• Print report 

Design Mode 
Use Design mode to create new reports and modify or rename existing reports. 
The options available for both creating and modifying reports are the same. 
Design mode options are also dynamic, based upon the type of report, included 
report data, and report presentation. Available options differ according to the type 
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of report that you are designing, but all reports require that you select the data to 
include and decide how that data will be sorted, ordered, filtered, and presented. 

Creating and Modifying Reports 
The following procedure guides you in the creation and modification of reports in 
Report Writer. 

To open a report with Report Writer: 

1. If you want to modify an existing report, select an existing report from the 
inventory in the left pane of the main Report Writer window. 

2. If you want to create a new report, click File > New Report, select the type 
of report that you would like to create, and then click OK. 

Each report, depending on its type, offers different configuration options on 
separate tabs of the Report Designer. The following is a guide to these tabs, 
including directions for options configuration. 

Notes: 

• The SQL query used to generate a report may be viewed in an additional tab. 
Click Report > Show SQL to add a read-only SQL tab to the Design window. 

• A preview of your report is also available at any time. Click Preview to enter 
Preview Mode, and then click Design to return to Design Mode. 

The following sections provide procedures for formatting your reports in Design 
mode. Each of the following sections corresponds to an available tab containing 
report formatting options. 

Note: Depending on the type of report, some of the following formatting tabs may 
not be available. 

General Options 
The General tab opens by default and shows titling and display options that may 
be configured as follows. 

To configure General options: 

1. Specify the Report Group, Report Title, Sub Title, and Description for 
your report. 

Note: If you use an existing report group name, the new report is added to 
that existing group in the left pane of the main window. 

2. Select the display Orientation of your report. 
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3. If you do not want to make this report available on your Orion Web 
Console, clear Make this Report available from the Orion website. 

Note: By default, most reports are made available for display on the Orion 
Network Performance Monitor Web Console. For more information about 
adding reports to Orion Web Console views, see “Customizing Views” in the 
SolarWinds Orion Network Performance Monitor Administrator Guide. 

Select Fields Options 
The Select Fields tab allows you to select the data fields that you want either to 
include in a new report or to modify in an existing report. Data fields are selected 
and configured as follows. 

To select and configure fields: 

1. Click Select Fields. In the Select Fields tab, fields are chosen, sort orders are 
established, and functions are specified. 

2. If you are creating a new report or adding fields to an existing report, 
click Browse (...), select Add a new field, and then dynamically define each 
new report field as follows: 

a. Click the asterisk after Field: and select the type of information that you 
want to include in the current report field. 

b. If you want to sort the data in the current field, click the sort asterisk 
and select a sort order. 

c. If you want to perform an operation on the data in the current field, 
click the function asterisk and select an operation. 

3. If you are modifying an existing report, click the Field, sort, or function 
that you want to change and select a new value as follows. 

a. Click the asterisk after Field: and select the type of information that you 
want to include in the current report field. 

b. If you want to sort the data in the current field, click the sort asterisk 
and select a sort order. 

c. If you want to perform an operation on the data in the current field, 
click the function asterisk and select an operation. 

4. If you want to test your selections as you assemble your report, click 
Execute SQL Query to view the current query results. 

5. If you want to preview your report, click Preview to run the query and 
display the results in Preview mode. Click Design in the toolbar to return to 
the Design Mode window. 
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6. If you want to delete a field or rearrange the order of the fields that are 
listed in your report, select a field, click Browse (...), and then select the 
appropriate action. 

Note: Unchecked fields are not displayed in your report, but their sort and 
function configurations are retained. 

Filter Results Options 
The Filter Results tab allows you to generate filter conditions for field data by 
selecting appropriate descriptors from the linked context menus. Results filters 
are configured as follows. 

To configure results filters: 

1. Click Browse (...), and then select from the following options: 

• Select Add a new elementary condition to generate a condition that is 
based on a direct comparison of network object data fields. 

• Select Add a new advanced elementary condition to generate a 
condition based on a comparison of device data fields and values. 

• Select Add a new complex condition to define a condition that filters 
other defined conditions. 

• Select Delete current condition to remove a selected condition. 

• Select Move current condition forward or Move current condition 
backward to change the order of your conditions accordingly. 

Note: The lists of available linked descriptors are dynamically generated in 
consideration of all other variables within the same condition. For more 
information, see “Understanding Condition Groups” in the SolarWinds Orion 
Network Performance Monitor Administrator Guide. 

2. Check or clear individual filter conditions to enable or disable their 
application, respectively, to your report. 

Top XX Records Options 
The Top XX tab allows you to limit the number of records that are shown in your 
report to either a top number or a top percentage of all results. Top XX options 
are configured as follows. 

To configure Top XX records: 

1. If you want to show all records in your report, select Show All Records. 

2. If you want to specify a truncated list of eligible items for your report, 
either select Show only the Top number Records or select Show the Top 
percentage % of Records, and then provide number or percentage values. 
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Time Frame Options 
The Time Frame tab allows you to limit the scope of your report to a specific 
period of time. Time Frame options are configured as follows. 

To configure Time Frame options: 

1. Select one of the following Time Frame options for your report: 

• Named Time Frame 

• Relative Time Frame 

• Specific Time Frame 

2. Select or provide required values. 

Notes: 

• If you receive a SQL Timeout error message, you may edit the timeout 
setting in the SWNetPerfMon.db file. By default, this file is located in the 
C:\Program Files\SolarWinds\Orion directory 

• Since the Relative Time Frame is continuously variable, reports run 
using it will likely show different results, even if they are run close 
together in time. 

Summarization Options 
The Summarization tab allows you to generate summaries of your results over 
specific periods of time. Summarization options are configured as follows. 

To configure results summarization: 

1. If you do not want to summarize your results, confirm that Do not 
Summarize the Results is selected. 

2. If you want to summarize your results over specific periods of time, 
select Summarize the Results by Hour, Date, Month, etc and then select 
the following: 

• Select the summarization period and then specify the location of the 
summary field for your report. 

• Select a location for the Summary Date/Time field. 

Report Grouping Options 
The Report Grouping tab allows you to group results by field descriptor within 
your report. Add, edit and delete report groups to organize the data in your 
report. Establish and edit report groups as follows. 



SolarWinds Orion Network Performance Monitor  Quick Start Guide 
 

 
Using Orion Network Performance Monitor  41 

To add and edit report groups: 

1. If you want to add a new report group, select a field from the list to define 
your group, and then click Add Report Group to add your selected field to 
the Report Groups list.  

Note: Use up and down arrows to change the grouping order accordingly. 

2. If you want to edit an existing report group, select the field from the 
Report Groups list, and then click Edit Report Group.  

3. The following options may be changed as needed: 

• The Group Header is the text that designates groups on your report. 

• The Web URL is the dynamic location of your published report with 
respect to your Orion Web Console. 

• Font size, face, color, and background may all be modified by clicking 
associated ellipses. 

• Alignment may be left, center, or right. 

• Check Transparent Background for better results with web reports. 

• Use the up and down arrows to change the grouping order accordingly. 

Field Formatting Options 
The Field Formatting tab allows you to customize the format of the various 
results fields in your report. Field formatting options are configured as follows. 

To format results fields: 

1. Select the field that you want to format, and then edit labels and select 
options as appropriate. 

Notes: 

• Formatting options for each field may differ according to field data type. 

• Check Hidden Field to hide any field in your report. 

2. If you want to view your changes at any time, click Preview. 

Customizing the Header and Footer Image 
The image that is displayed at the top and bottom of each report can be 
changed. To add your company logo or any other image as the header and 
footer image in your reports, rename your logo or custom image file as 
ReportHeader.jpg, and then copy it to the SolarWinds\Orion folder. 

Note: The image must be in JPEG format with a height of 150 pixels or less. 
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Example of Report Creation 
The following procedure generates an example report of network device 
availability information over the previous week. The final report is sorted so that 
the worst errors are viewed first. Down nodes that are still down are at the top 
with all devices listed in order of increasing availability. 

Note: At any point during the creation of a report (or perhaps at many points), 
you may save what you have done by clicking File > Save. The first time you 
save you must give your report a filename or accept the default, which will be the 
report title that you assign in the following procedure. 

To generate an example report of network device availability information: 

1. Click File > New Report. 

2. The example calls for a report on availability over the past week, so select 
Historical Availability Details, and then click OK. 

3. Type My Reports in the Report Group field. 

4. Enter Last Week’s Availability as the Report Title. 

5. Select Portrait for the paper orientation. 

6. Click Select Fields. 

7. Click Browse (...), and then select Add a new field. 

8. Click the Field asterisk, and then select Network Nodes > Node Details > 
Node Name. 

9. Click Browse (...), and then select Add a new field. 

10. Click the Field asterisk, and then select Network Nodes > Node Status > 
Status. 

11. Click Browse (...), and then select Add a new field. 

12. Click the Field asterisk, and then select Network Nodes > Node Status > 
Status Icon. 

Note: While this field makes a distinct visual difference for a report viewed in 
color, it will make little or no difference if printed in black and white. 

13. Click Execute SQL Query to view the report data in the preview window. 

14. If you want to see the status icon before the status description, click 
Status Icon to move Browse (...) to the Status Icon line, and select Move 
Current Field Backward. 



SolarWinds Orion Network Performance Monitor  Quick Start Guide 
 

 
Using Orion Network Performance Monitor  43 

15. Click Execute SQL Query. 

Note: The report should show information about both current and historical 
status. Current status entries must be relabeled to avoid confusion. 

16. Click Field Formatting. 

17. Select Status from the field list. 

18. Change the Column Header entry to Current Status. 

19. Select Status_Icon from the field list. 

20. Change the Column Header entry to Current Status. 

21. Click Execute SQL Query. 

Note: Column widths are adjustable. To change a column width, place your 
cursor on the column divider and drag it to a different position. 

22. Click Select Fields. 

23. Click the sort asterisk on the Status field line, and then select descending. 

24. Click Execute SQL Query to confirm your choice. 

25. Click Browse (...), and then select Add a new field. 

26. Click the Field asterisk, and then select Historical Response Time and 
Availability > Availability. 

27. Click the sort asterisk on the new line, and then select ascending. 

28. Click Execute SQL Query to view the report. 

29. Click Time Frame. 

30. Select Relative Time Frame, type 7 in the text field, and then select Days 
from the list. 

31. If you want to break down the report day-by-day, click Summarization and 
specify your choices. 

32. If you want to filter your report, click Filter Results and specify filter rules. 

33. Click File > Save to save your work. 
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Using Orion NPM Alerts 
An alert is a configurable response to the behavior of a monitored object. One of 
the many powerful features of Orion Network Performance Monitor is its ability to 
alert on almost every aspect of your network. You can trigger responses when an 
alert is generated and when it is resolved; you can create simple or complex 
conditions under which an alert is triggered or reset; you can suppress alerts 
when a set of simple or complex conditions exist; and you can create an 
escalation path that triggers when an alert remains unresolved. 

When monitoring your network, you can take advantage of Orion NPM alerts to 
draw attention to a number of issues, including the following: 

• Unexpected one-time or sustained high CPU load 

• Loss of available memory or insufficient hard drive space 

• Slow response time 

• Disproportionate interface utilization or excessive interface errors 

Both the triggering of an alert and the resetting of an alert can trigger a number of 
actions, including the actions listed in the following table. 

Note: Windows Server 2008 does not support Windows Net Messaging, so the 
Send a Windows Net message alert action is not available to Orion NPM 
installations on Windows Server 2008. 

Orion NPM Alert Actions 
Play a .wav sound Send an email or page Log alerts to the Windows Event Log 
Log alerts to a file Text-to-Speech output Log alerts to the Orion NPM Event Log 
Email a web page Send a Syslog message Send a Windows Net message 
Send SNMP traps Execute an external program Execute an external VB script 

Configuring Orion NPM Alerts 
The following sections provide steps required to configure a few example alerts.  

High CPU Load Alert Example 
The following procedure creates a high CPU load alert. 

To configure a high CPU load alert: 

1. Click Start > All Programs > SolarWinds Orion > Advanced Alert 
Manager. 

2. Click View > Configure Alerts. 

3. Click New on the Manage Alerts window. 

4. Type CPU Load High in the Name of Alert field on the General tab. 
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5. Provide an alert description in the Enter a description for this Alert field. 

6. Check Enable this Alert. 

7. Click the Trigger Condition tab. 

8. Select Node from the Type of Property to Monitor list. 

9. Click Add, and then select Simple Condition. 

10. Click is equal to, and then select greater or equal. 

11. Click the first *, and then click Network Nodes > Current CPU Memory > 
CPU Load. 

12. Click 0 after is greater than or equal to, and then type 80. 

13. Click the Reset Condition tab. 

14. Select Reset this alert when the following conditions are met. 

Note: Configuring a reset condition ensures that stale alerts do not remain 
prominent in your alert log. 

15. Click Add, and then select Simple Condition. 

16. Click is equal to, and then select less or equal. 

17. Click the first *, and then click Network Nodes > Current CPU and 
Memory > CPU Load. 

18. Click 0 after is less than or equal to, and then type 70. 

19. Click the Trigger Actions tab. 

20. Click Add New Action. 

21. Select your preferred means of notification, click OK, and then complete the 
displayed tabs as appropriate. 

Note: As an example, select Send an Email/Page, and then specify the 
appropriate information on tabs of the Edit Email/Page Action window to 
receive an email whenever the High CPU Load alert is triggered. For more 
information about available alert actions, see “Available Alert Actions” in the 
SolarWinds Orion Network Performance Monitor Administrator Guide. 

22. After completing the configuration of your selected alert action, click OK. 

23. If you want to specify an action to execute when this alert is reset, 
complete the following steps: 

Note: For more information about alert actions, see “Available Alert Actions” 
in the SolarWinds Orion Network Performance Monitor Administrator Guide. 

a. Click the Reset Actions tab. 

b. Click Add New Action. 
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c. Select an action to execute when the alert is reset, and then click OK. 

d. Complete the displayed tabs as appropriate, and then click OK. 

24. Click OK when you are satisfied with the configuration of your alert. 

Sustained High CPU Load Alert Example 
The following procedure creates a sustained high CPU load alert. 

Note: This alert differs from the High CPU Load Alert created in the previous 
procedure in that the alert in this example procedure allows the triggering 
condition to persist for an hour before the trigger action fires. 

To configure a sustained high CPU load alert: 

1. Click Start > All Programs > SolarWinds Orion > Advanced Alert 
Manager. 

2. Click View > Configure Alerts. 

3. Click New on the Manage Alerts window. 

4. Type CPU Load Sustained High in the Name of Alert field on the General 
tab. 

5. Provide an alert description in the Enter a description for this Alert field. 

6. Check Enable this Alert. 

7. Click the Trigger Condition tab, and then select Node from the Type of 
Property to Monitor list. 

8. Click Add, and then select Simple Condition. 

9. Click is equal to, and then select greater or equal. 

10. Click the first *, and then click Network Nodes > Current CPU and 
Memory > CPU Load. 

11. Click 0 after is greater than or equal to, and then type 80. 

12. At the bottom of the window, next to Do not trigger this action until 
condition exists for more than, type 1, and then select Hours. 

13. Click the Trigger Actions tab, and then click Add New Action. 

14. Select your preferred means of notification, click OK, and then complete the 
displayed tabs as appropriate. 

Note: As an example, select Send an Email/Page, and then specify the 
appropriate information on tabs of the Edit Email/Page Action window to 
receive an email whenever the High CPU Load alert is triggered. For more 
information about available alert actions, see “Available Alert Actions” in the 
SolarWinds Orion Network Performance Monitor Administrator Guide. 
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15. After completing the configuration of your selected alert action, click OK. 

16. If you want to specify an action to execute when this alert is reset, 
complete the following steps: 

a. Click the Reset Actions tab, and then click Add New Action. 

b. Select an action to execute when the alert is reset, and then click OK. 

c. Complete the displayed tabs as appropriate, and then click OK. 

Note: For more information about available alert actions, see “Available Alert 
Actions” in the SolarWinds Orion Network Performance Monitor Administrator 
Guide. 

17. Click OK when you are satisfied with the configuration of your alert. 

Sustained Loss of Available Memory Alert Example 
The following procedure creates a sustained loss of available memory alert. 

Note: This alert allows the low memory triggering condition to persist for 30 
minutes before the configured trigger action fires. 

To configure a loss of available memory alert: 

1. Click Start > All Programs > SolarWinds Orion > Advanced Alert 
Manager. 

2. Click View > Configure Alerts. 

3. Click New on the Manage Alerts window. 

4. Type Memory Low in the Name of Alert field on the General tab. 

5. Check Enable this Alert. 

6. Click the Trigger Condition tab, and then select Node from the Type of 
Property to Monitor list. 

7. Click Add, and then select Simple Condition. 

8. Click is equal to, and then select less or equal. 

9. Click the first *, and then click Network Nodes > Current CPU and 
Memory > Percent Memory Available. 

10. Click 0 after is less than or equal to, and then type 10. 

11. At the bottom of the window, next to Do not trigger this action until 
condition exists for more than, type 30, and then select Minutes. 

12. Click the Trigger Actions tab, and then click Add New Action. 
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13. Select your preferred means of notification, click OK, and then complete the 
displayed tabs as appropriate. 

Note: As an example, select Send an Email/Page, and then specify the 
appropriate information on tabs of the Edit Email/Page Action window to 
receive an email whenever the High CPU Load alert is triggered. For more 
information about available alert actions, see “Available Alert Actions” in the 
SolarWinds Orion Network Performance Monitor Administrator Guide. 

14. After completing the configuration of your selected alert action, click OK. 

15. If you want to specify an action to execute when this alert is reset, 
complete the following steps: 

Note: For more information about available alert actions, see “Available Alert 
Actions” in the SolarWinds Orion Network Performance Monitor Administrator 
Guide. 

a. Click the Reset Actions tab, and then click Add New Action. 

b. Select an action to execute when the alert is reset, and then click OK. 

c. Complete the displayed tabs as appropriate, and then click OK. 

16. Click OK when you are satisfied with the configuration of your alert. 

Insufficient Hard Drive Space Alert Example 
The following procedure creates a low hard drive space alert. 

To configure an insufficient hard drive space alert: 

1. Click Start > All Programs > SolarWinds Orion > Advanced Alert 
Manager. 

2. Click View > Configure Alerts. 

3. Click New on the Manage Alerts window. 

4. Type Disk Space Low in the Name of Alert field on the General tab. 

5. Check Enable this Alert. 

6. Click the Trigger Condition tab, and then select Volume from the Type of 
Property to Monitor list. 

7. Click Add, and then select Simple Condition. 

8. Click is equal to, and then select less or equal. 

9. Click the first *, and then click Volumes > Volume Status > Volume 
Percent Available. 

10. Click 0 after is less than or equal to, and then type 5. 

11. Click the Trigger Actions tab, and then click Add New Action. 
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12. Select your preferred means of notification, click OK, and then complete the 
displayed tabs as appropriate. 

Note: As an example, select Send an Email/Page, and then specify the 
appropriate information on tabs of the Edit Email/Page Action window to 
receive an email whenever the High CPU Load alert is triggered. For more 
information about available alert actions, see “Available Alert Actions” in the 
SolarWinds Orion Network Performance Monitor Administrator Guide. 

13. After completing the configuration of your selected alert action, click OK. 

14. If you want to specify an action to execute when this alert is reset, 
complete the following steps: 

Note: For more information about available alert actions, see “Available Alert 
Actions” in the SolarWinds Orion Network Performance Monitor Administrator 
Guide. 

a. Click the Reset Actions tab, and then click Add New Action. 

b. Select an action to execute when the alert is reset, and then click OK. 

c. Complete the displayed tabs as appropriate, and then click OK. 

15. Click OK when you are satisfied with the configuration of your alert. 

Sustained Slow Response Time Alert Example 
The following procedure creates a sustained slow response time alert. 

Note: This alert allows the slow response time triggering condition to persist for 
10 minutes before the configured trigger action fires. 

To configure a sustained slow response time alert: 

1. Click Start > All Programs > SolarWinds Orion > Advanced Alert 
Manager. 

2. Click View > Configure Alerts. 

3. Click New on the Manage Alerts window. 

4. Type Response Time Slow in the Name of Alert field on the General tab. 

5. Check Enable this Alert. 

6. Click the Trigger Condition tab, and then select Node from the Type of 
Property to Monitor list. 

7. Click Add, and then select Simple Condition. 

8. Click is equal to, and then select greater or equal. 

9. Click the first *, and then click Network Nodes > Current Response Time > 
Response Time. 
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10. Click 0 after is greater than or equal to, and then type 150. 

Note: Response time is measured in milliseconds. 

11. At the bottom of the window, next to Do not trigger this action until 
condition exists for more than, type 10, and then select Minutes. 

12. Click the Trigger Actions tab, and then click Add New Action. 

13. Select your preferred means of notification, click OK, and then complete the 
displayed tabs as appropriate. 

Note: As an example, select Send an Email/Page, and then specify the 
appropriate information on tabs of the Edit Email/Page Action window to 
receive an email whenever the High CPU Load alert is triggered. For more 
information about available alert actions, see “Available Alert Actions” in the 
SolarWinds Orion Network Performance Monitor Administrator Guide. 

14. After completing the configuration of your selected alert action, click OK. 

15. If you want to specify an action to execute when this alert is reset, 
complete the following steps: 

Note: For more information about available alert actions, see “Available Alert 
Actions” in the SolarWinds Orion Network Performance Monitor Administrator 
Guide. 

a. Click the Reset Actions tab, and then click Add New Action. 

b. Select an action to execute when the alert is reset, and then click OK. 

c. Complete the displayed tabs as appropriate, and then click OK. 

16. Click OK when you are satisfied with the configuration of your alert. 

Sustained Excessive Interface Utilization Alert Example 
The following procedure creates a sustained excessive interface utilization alert. 

Note: This alert allows the excessive interface utilization triggering condition to 
persist for 10 minutes before the configured trigger action fires. 

To configure an excessive interface utilization alert: 

1. Click Start > All Programs > SolarWinds Orion > Advanced Alert 
Manager. 

2. Click View > Configure Alerts. 

3. Click New on the Manage Alerts window. 

4. Type Interface Utilization (Excessive) in the Name of Alert field on 
the General tab. 

5. Check Enable this Alert. 
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6. Click the Trigger Condition tab, and then select Interface from the Type of 
Property to Monitor list. 

7. Click Add, and then select Simple Condition. 

8. Click is equal to, and then select greater or equal. 

9. Click the first *, and then click Interfaces > Current Traffic > Average 
Xmit+Recv Percent Utilization. 

10. Click 0 after is greater than or equal to, and then type 80. 

11. At the bottom of the window, next to Do not trigger this action until 
condition exists for more than, type 10, and then select Minutes. 

12. Click the Trigger Actions tab, and then click Add New Action. 

13. Select your preferred means of notification, click OK, and then complete the 
displayed tabs as appropriate. 

Note: As an example, select Send an Email/Page, and then specify the 
appropriate information on tabs of the Edit Email/Page Action window to 
receive an email whenever the High CPU Load alert is triggered. For more 
information about available alert actions, see “Available Alert Actions” in the 
SolarWinds Orion Network Performance Monitor Administrator Guide. 

14. After completing the configuration of your selected alert action, click OK. 

15. If you want to specify an action to execute when this alert is reset, 
complete the following steps: 

Note: For more information about available alert actions, see “Available Alert 
Actions” in the SolarWinds Orion Network Performance Monitor Administrator 
Guide. 

a. Click the Reset Actions tab, and then click Add New Action. 

b. Select an action to execute when the alert is reset, and then click OK. 

c. Complete the displayed tabs as appropriate, and then click OK. 

16. Click OK when you are satisfied with the configuration of your alert. 

Interface Error Alert Example 
The following procedure creates an interface error alert. 

To configure an interface error alert: 

1. Click Start > All Programs > SolarWinds Orion > Advanced Alert 
Manager. 

2. Click View > Configure Alerts. 

3. Click New on the Manage Alerts window. 
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4. Type Interface Receive Errors (Excessive) in the Name of Alert field 
on the General tab. 

5. Check Enable this Alert. 

6. Click the Trigger Condition tab, and then select Interface from the Type of 
Property to Monitor list. 

7. Click Add, and then select Simple Condition. 

8. Click is equal to, and then select greater or equal. 

9. Click the first *, and then click Interfaces > Errors and Discards > Recv 
Errors – This Hour. 

10. Click 0 after is greater than or equal to, and then type 50. 

11. Click the Trigger Actions tab, and then click Add New Action. 

12. Select your preferred means of notification, click OK, and then complete the 
displayed tabs as appropriate. 

Note: As an example, select Send an Email/Page, and then specify the 
appropriate information on tabs of the Edit Email/Page Action window to 
receive an email whenever the High CPU Load alert is triggered. For more 
information about available alert actions, see “Available Alert Actions” in the 
SolarWinds Orion Network Performance Monitor Administrator Guide. 

13. After completing the configuration of your selected alert action, click OK. 

14. If you want to specify an action to execute when this alert is reset, 
complete the following steps: 

Note: For more information about available alert actions, see “Available Alert 
Actions” in the SolarWinds Orion Network Performance Monitor Administrator 
Guide. 

a. Click the Reset Actions tab, and then click Add New Action. 

b. Select an action to execute when the alert is reset, and then click OK. 

c. Complete the displayed tabs as appropriate, and then click OK. 

15. Click OK when you are satisfied with the configuration of your alert. 
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Viewing Alerts in the Orion Web Console 
Once you have configured alerts in Orion NPM, the Orion Web Console provides 
both an Alerts view and alerts resources that you can use to continuously monitor 
the status of your network and its devices. The following sections provide the 
steps required to use alerts for immediate notification of potential problems on 
your network. 

Using the Alerts View 
Orion provides the Alerts view on the Views toolbar, allowing you to quickly 
review all triggered alerts on your network. The following procedure configures 
the Alerts view to display the specific alerts you need to see at any time. 

To use the Alerts view to review network alerts: 

1. Click Start > All Programs > SolarWinds Orion > Orion Web Console. 

2. Log in to the Web Console as an administrator, and then click Alerts in the 
Views toolbar. 

3. Select Advanced from the Select an Alert Engine list. 

Note: The example alerts created in the “Configuring Orion NPM Alerts” 
section on page 44 are all advanced alerts. For more information about alerts 
in Orion NPM, see “Creating and Managing Alerts” in the SolarWinds Orion 
Network Performance Monitor Administrator Guide. 

4. If you want to limit the list of alerts to only those dealing with a single 
device, select the specific device from the Select a Network Device list. 

Note: This option is only available if Orion NPM has fired alerts on multiple 
network devices. 

5. If you want to limit the list of alerts to only those dealing with a single 
type of device, select the specific device type from the Select a Type of 
Device list. 

Note: This option is only available if Orion NPM is monitoring multiple types 
of network devices. 

6. If you want to limit the list of alerts to only those of a single type, select 
the specific alert type from the Type of Alert list. 

Note: This option is only available if Orion NPM has fired multiple types of 
alerts. 

7. If you want to group the list of alerts by type or by device, select the 
appropriate grouping criterion (Type of Alert or Network Node) from the 
Group By list. 

8. Click Refresh to update the alerts list with your new settings. 
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The Alerts view shows all alerts matching your provided criteria. For each alert, 
the Alerts view provides the time the alert was triggered, the network device and 
object that triggered the selected alert, the measure value that triggered the alert, 
and any message associated with the triggered alert. 

Adding the Active Alerts Resource to Orion Web Console Views 
Orion provides the Active Alerts resource for use in Orion Web Console views, 
allowing you to tailor your views of alerts to specific devices on your network. The 
following steps add the Active Alerts resource to Orion Web Console views. 

To add the Active Alerts resource to an Orion Web Console view: 

1. Log in to the Web Console as an administrator, and then click Admin in the 
Views toolbar. 

2. Click Manage Views in the Views grouping. 

3. Click the view to which you want to add the Active Alerts resource, and then 
click Edit. 

Note: The scope of an Active Alerts resource is limited by the scope of the 
view in which the Active Alerts resource displays. For example, if you add an 
Active Alerts resource to a Node Details view, the added Active Alerts 
resource only displays alerts relevant to the viewed node. In the same way, 
the Active Alerts resource in the Network Summary Home view displays all 
active alerts on your entire network. 

4. Click + next to the view column in which you want to display the Active Alerts 
resource. 

5. Click + next to Alerts to expand the list of available alerts resources. 

6. Check All Triggered Alerts, and then click Submit. 

Additional Orion NPM Features 
Orion NPM provides a number of additional tools and features that can enhance 
your ability to fully monitor the performance of your network. The following 
sections provide brief descriptions of these additional tools and features. 

Monitoring EnergyWise Devices 
SolarWinds has partnered with Cisco to present EnergyWise to optimize energy 
usage on your network. EnergyWise is a Cisco technology developed to help you 
cut enterprise energy costs, address environmental concerns, and adhere to 
government directives around green technologies. By deploying EnergyWise 
capable devices and by enabling their energy-saving features, you can run 
business-critical systems in a fully powered state while allowing less critical 
devices on Power over Ethernet (PoE) ports to power down or drop into standby 
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during off-peak hours. Orion NPM provides the EnergyWise Summary view and 
related EnergyWise resources to help you monitor the energy expended on your 
network and the energy savings provided by EnergyWise-enabled devices. For 
more information about monitoring EnergyWise-enabled devices, see “Monitoring 
EnergyWise Devices” in the SolarWinds Orion Network Performance Monitor 
Administrator Guide. 

Using Maps in Orion NPM 
Orion Network Atlas is a powerful tool for creating custom maps and network 
diagrams. The maps created in Orion Network Atlas enable users to view a 
graphical depiction of their network in the Orion Web Console. You can also use 
the maps to create network documentation, which can then be printed and 
exported as needed. Creating a map can be as simple as selecting a background 
image, dragging nodes to the image, and connecting them with a few lines. 
However, Network Atlas presents options enabling you to be as creative as you 
like. For more information about creating network maps for use with Orion NPM, 
see the SolarWinds Orion Network Atlas Administrator Guide. 

Monitoring Wireless Networks 
Orion NPM can monitor any 802.11 IEEE-compliant autonomous access point 
(AP) or wireless controller. Details about your access points (AP), wireless 
clients, wireless controllers, thin APs, and rogue APs can all be monitored using 
Orion NPM. Wireless device monitoring is configured, customized, and managed 
using the Orion Web Console. For more information about monitoring wireless 
networks, see “Monitoring Wireless Networks” in the SolarWinds Orion Network 
Performance Monitor Administrator Guide. 

Monitoring VMware ESX Servers 
Orion NPM gives you the ability to monitor the performance of VMware ESX 
servers and the multiple virtual machines (VMs) hosted by ESX servers on your 
network. Available resources include lists of VMs on selected ESX servers, 
performance details for ESX servers and hosted VMs, and relevant alerts, charts 
and reports. For more information about monitoring VMware ESX Servers, see 
“Managing Devices in the Web Console” in the SolarWinds Orion Network 
Performance Monitor Administrator Guide. 

Using Custom Properties in Orion NPM 
Orion NPM provides the Custom Property Editor, allowing you to add custom 
properties to any interface, node, or volume. Custom properties are additional 
fields, such as country, asset tag, or serial number that you can define and store 
in your Orion Network Performance Monitor database. Once properties are 
added, they are available for display and filtering within the Orion Web Console 
and other Orion applications. For more information about custom properties, see 
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“Creating Custom Properties” in the SolarWinds Orion Network Performance 
Monitor Administrator Guide. 

Using SNMP Traps in Orion NPM 
The Orion NPM Trap Viewer application is used in Orion NPM to configure alerts, 
view and search trap messages, and to apply rules to filter out certain types of 
messages. Because the SolarWinds Trap service has the ability to open multiple 
connections to the SQL server database, it can handle large quantities of 
incoming trap messages. For more information about using SNMP traps in Orion 
NPM, see “Monitoring SNMP Traps” in the SolarWinds Orion Network 
Performance Monitor Administrator Guide. 

Using Syslog Messaging in Orion NPM 
The Orion Syslog Server allows the Network Performance Monitor to receive and 
process Syslog messages from any type of device. Syslog messages are 
realtime messages that network devices generate to notify about a specific event 
within the device. The Syslog Viewer is used to configure alerts, to view and 
search Syslog messages, and to apply rules to filter out certain types of 
messages. Because the Syslog service has the ability to open multiple 
connections to your SQL server, it can handle large numbers of simultaneously 
incoming Syslog messages. For more information about using Syslog messaging 
in Orion NPM, see “Monitoring Syslog Messages” in the SolarWinds Orion 
Network Performance Monitor Administrator Guide. 

Using Universal Device Pollers in Orion NPM 
Using Universal Device Pollers, Orion NPM has the ability to monitor more than 
just network status, availability, bandwidth, and errors. With Orion Universal 
Device Pollers, you can monitor virtually any statistic that your network devices 
can record. Orion Universal Device Pollers can both collect realtime statistics and 
record historical statistics. Additionally, with Universal Device Poller transforms, 
you can mathematically manipulate the results of multiple pollers to create your 
own network performance metrics. All network information collected from 
Universal Device Pollers is easily accessible within the Orion Web Console. For 
more information about using Universal Device Pollers in Orion NPM, see 
“Monitoring MIBs with Universal Device Pollers” in the SolarWinds Orion Network 
Performance Monitor Administrator Guide. 

Viewing External Websites 
With the external website view feature, any Orion NPM administrator can make 
any website accessible as an Orion Web Console view. Designated external 
websites display as items in the Orion Web Console Views tool bar. For more 
information, see “Creating and Editing External Website Views” in the 
SolarWinds Orion Network Performance Monitor Administrator Guide. 
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Chapter 5 

Monitoring Your Network with Orion NPM 

You can begin seeing meaningful network monitoring and management benefits 
from your installation of Orion NPM in an hour or less. The following sections 
detail some of the network monitoring abilities that come standard with an 
installation of Orion NPM. 

Monitoring Network Performance 
Once Orion NPM is properly configured to show network performance data, a 
primary use case is the generation of charts and reports to confirm compliance 
with current service level agreements (SLAs).The following sections provide 
procedures showing steps to start monitoring your network with Orion NPM.  

Viewing Node and Interface Charts and Gauges 
The following procedure guides you through locating and viewing the charts and 
gauges that are immediately helpful when monitoring network performance. 

Notes: 

• For more information about viewing Orion NPM resources in addition to 
the defaults described in the following procedure, see “Customizing 
Views” in the SolarWinds Orion Network Performance Monitor 
Administrator Guide. 

• Clicking a gauge allows you to view a customizable chart of the collected 
data over time. Clicking a chart allows you to customize the time period, 
sample interval, and chart size, among other options. 

• If a resource displays No Data for Selected Time Period, Orion 
NPM has not had sufficient time under the current settings to collect 
meaningful data for the viewed resource. Click Edit in the resource 
header, and then select smaller values for both the Time Period for 
Chart and Sample Interval options. 

To view node and interface charts and gauges: 

1. Click Start > All Programs > SolarWinds Orion > Orion Web Console. 

2. Log in to the Web Console as an administrator. 

3. Expand a node grouping in the All Nodes resource of the Network Summary 
Home page, and then click the node you want to explore.  
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4. Review the resulting Node Details page, ensuring you pay close attention to 
the following ICMP-based near-realtime gauges, statistical gauges, and 
statistical charts: 

• Average Response Time & Packet Loss gauge 

• Average Response Time & Packet Loss statistical chart 

• CPU Load & Memory Utilization gauge showing the last polled values 

• Min/Max Average CPU Load statistical chart 

5. If you navigated away from your Node Details page, click Home in the 
Views toolbar to return to the Network Summary Home page, and then 
expand and select a node in the All Nodes resource on the Network 
Summary Home page. 

6. Locate the Current Percent Utilization of Each Interface resource of the Node 
Details page, and then click any interface.  

7. Review the resulting Interface Details page, ensuring that you pay close 
attention to the following statistical gauges and charts: 

• Percent Utilization gauges 

• Percent Utilization - Line Chart 

• Min/Max/Average bps In/Out chart 

• Min/Max/Average packets In/Out chart 

• In/Out Errors and Discards chart 

• Total Bytes Transferred chart 

8. Click Reports in the Views toolbar. 

9. Expand Current Volume Status, and then click Available Space on each 
Volume. 

10. Locate the volumes you are managing and review the Volume Size, Space 
Available, and Percent Available statistics. 

11. If you want a hard copy of the currently viewed report, click Printable 
Version in the upper right corner of the web console view, click File > Print, 
configure print options, and then click Print. 
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Viewing Network Performance Reports 
The following procedure guides you through locating and viewing the Orion NPM 
reports that are immediately helpful when monitoring network performance. 

Note: For more information about viewing creating see “Creating Reports” in the 
SolarWinds Orion Network Performance Monitor Administrator Guide. 

To view Orion NPM reports: 

1. Click Start > All Programs > SolarWinds Orion > Orion Web Console. 

2. Log in to the Web Console as an administrator. 

3. Click Reports in the Views toolbar. 

4. Click + next to the type of report you want to view. 

5. Click the title of any report that you want to view. 

Note: Depending on the length of time that Orion NPM has been monitoring 
your network, some reports may not return useful results. For example, if you 
have just installed Orion NPM and added nodes today, reports covering time 
periods prior to today may not return useful information. SolarWinds 
recommends you tailor Orion NPM reports to match desired monitoring 
periods as closely as possible. For more information, see “Creating Reports” 
in the SolarWinds Orion Network Performance Monitor Administrator Guide. 

6. If you want a hard copy of the currently viewed report, click Printable 
Version in the upper right corner of the web console view, click File > Print, 
configure print options, and then click Print. 

Orion NPM reports viewed in the web console are interactive. Clicking any report 
heading toggles column values into ascending or descending order, and clicking 
any ldevice opens the corresponding Device Details view in the web console. 

Managing Your Servers 
You can see the benefits of using Orion NPM to monitor network servers in as 
little as an hour of network monitoring. Before continuing, confirm that your Orion 
NPM database includes any and all of the following objects on your network: 

• Windows servers and workstations 

• VMware ESX servers 

• Linux, Solaris, HPUX, AIX, and AIS servers 

• Microsoft Exchange and SQL Servers 

For more information about adding network devices to your Orion NPM 
database, see “Managing Devices in the Orion Web Console” on page 27. 
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Viewing Server Management Charts and Reports 
The following procedure guides you through locating and reviewing the charts 
and gauges that are immediately helpful when managing mission-critical servers. 

To review server management charts and reports: 

1. Click Start > All Programs > SolarWinds Orion Network Performance 
Monitor > Orion Web Console. 

2. Log in to the Web Console. The default user is admin with a blank password. 

3. Expand a node grouping in the All Nodes section of the Network Summary 
page, and then click a server you want to explore.  

4. Review the resulting Node Details page, ensuring you pay close attention to 
the following resources: 

• Average Response Time & Packet Loss gauge 

• Average Response Time & Packet Loss chart 

• CPU Load & Memory Utilization gauge 

• Min/Max Average CPU Load chart 

Notes:  

• Consider using this data to ensure you comply with your current service 
level agreements (SLAs). 

• Clicking a gauge allows you to view customizable chart of the collected 
data over time. Clicking a chart allows you to customize the time period, 
sample intervals, among other data points. 

5. If you navigated away from your Node Details page, click the Network 
Performance Monitor tab to return to the Network Summary page, and then 
expand and select a node in the All Nodes section of the Network Summary 
page.  

6. Locate the Current Percent Utilization of Each Interface section of the Node 
Details page, and then click an interface.  

7. Review the traffic and error charts and reports. 

8. Click Reports on the menu bar. 

9. Expand Current Volume Status, and then click Available Space on each 
Volume.  

10. Locate the volumes you are managing and review their available and percent 
available space statistics. 
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11. Complete the following procedure to add the Network Trends view to the 
Admin menu bar: 

a. Click Admin on the menu bar. 

b. Click Customize Menu Bars in the left navigation pane. 

c. Click Edit under the Admin menu bar. 

d. Drag Network Trends from the Available items menu to the Selected 
items menu, and then click Submit. 

12. Click Network Trends on the menu bar.  

Note: Due to the amount of data queried from the database, the Network 
Trends resources may take a significant time to load. You can also edit the 
number of resources included in the view to reduce the time to load. For 
more information about customizing views, see the Administrator Guide. 

13. Review the resulting Network Trends page, ensuring that you pay close 
attention to the following reports: 

• Network Wide Average Response Time 

• Network Wide Min/Max/Average Response Time 

• Network Wide Average Utilization 

• Network Wide Availability 

Configuring Key Server Management Alerts 
Using the alert configuration procedures detailed in the “Using Orion NPM Alerts” 
section on page 44 as guides, consider configuring the following alerts with a 
trigger action that pages the appropriate operator: 

• Node status is equal to down 

• CPU load is greater than 90% for over 5 minutes 

• Percent memory available is less than 5 

• Volume space available is less than 100MB 

• Average transmit and receive percent utilization is greater than 50 

For more information about configuring alerts in Orion NPM, see “Creating and 
Managing Alerts” in the SolarWinds Orion Network Performance Monitor 
Administrator Guide. 
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Diagnosing Network Availability 
The benefits of diagnosing network availability with Orion Network Performance 
Monitor become apparent in approximately one week. Before continuing, confirm 
that your Orion NPM database includes any and all of the following objects on 
your network: 

• All network devices, including routers, switches, firewall, VPN devices, and 
servers (Unix and Windows). 

• All network interfaces and connections, including physical, virtual, and 
subinterfaces. 

• All device resources, including CPU, memory, volumes, and buffers. 

For more information about adding network devices to your Orion NPM 
database, see “Managing Devices in the Orion Web Console” on page 27. 

Viewing Network Availability Charts and Reports 
The following procedure guides you through locating and reviewing the charts 
and reports that deal with network availability analysis and trends. 

To view network availability charts and reports: 

1. Click Start > All Programs > SolarWinds Orion Network Performance 
Monitor > Orion Web Console. 

2. Log in to the Web Console. The default user is admin with a blank password. 

3. Expand a node grouping in the All Nodes section of the Network Summary 
page, and then click a server you want to explore.  

4. Review the resulting Node Details page, ensuring that you pay close 
attention to the following resources: 

• Average Response Time & Packet Loss chart showing the last 7 days of 
data 

• Availability Statistics table 

5. Click Reports on the menu bar. 

6. Expand Daily Node Availability, and then click Availability – This Month.  

7. Review the report, and then click Reports on the menu bar. 

8. Expand Availability, and then click Availability – Last Year. 

9. Review the report. 
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10. Click Network Trends on the menu bar.  

Note: Due to the amount of data queried from the database, the Network 
Trends resources may take a significant time to load. To reduce the load 
time, you can edit the number of resources included in the view. For more 
information, see the SolarWinds Orion Network Performance Monitor 
Administrator Guide. 

11. Review the Network Trends page, paying attention to the following reports: 

• Network Wide Average Response Time 

• Network Wide Availability 

Configuring Key Network Availability Alerts 
Using the alert configuration procedures detailed in the “Using Orion NPM Alerts” 
section on page 44 as guides, consider configuring the following alerts with a 
trigger action that pages the appropriate operator: 

• Node status, interface status, or volume status is equal to down 

• Alert based on the receipt of a specific SNMP trap -- use the Trap Viewer to 
configure these alerts 

• Alert based on the receipt of a specific Syslog message – use the Syslog 
Viewer to configure these alerts 

For more information about configuring alerts in Orion NPM, see “Creating and 
Managing Alerts” in the SolarWinds Orion Network Performance Monitor 
Administrator Guide. 

Analyzing Usage Trends 
Using Orion NPM to analyze trends on your network requires an extended period 
of time to collect enough data to generate useful charts and reports. In 3 months, 
the amount of data collected by Orion NPM should be sufficient to see real trends 
and predict possible capacity shortfalls. Before continuing, confirm that your 
Orion NPM database includes the following objects on your network: 

• All network devices, including routers, switches, firewall, VPN devices, and 
servers (Unix and Windows). 

• All network interfaces and connections, including physical, virtual, and 
subinterfaces. 

• All device resources, including CPU, memory, volumes, and buffers. 

For more information about adding network devices to your Orion NPM 
database, see “Managing Devices in the Orion Web Console” on page 27. 
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Viewing Useful Node Trend Resources 
The Orion Web Console provides many useful resources that can help you 
recognize trends and bottlenecks at the node level. The following charts and 
gauges are available as resources within Orion Web Console views: 

• Average Response Time & Packet Loss chart 

• Min/Max/Average CPU Load chart 

• CPU Load & Memory Utilization gauges 

Note: Optimize the ability of charts to display longer time periods by clicking Edit 
in the resource header to customize each chart as you require. 

Orion NPM also provides reports that can help you recognize trends and 
bottlenecks at the node level on your network. The following node-level reports, 
available by clicking Reports in the Views toolbar, track node trends: 

• Availability reports 

• Historical Response Time reports 

• Historical CPU and Memory reports 

• Historical Traffic reports 

Viewing Useful Interface Trend Resources 
The Orion Web Console provides many useful resources that can help you 
recognize trends and bottlenecks at the interface level. The following charts are 
available as resources within Orion Web Console views: 

• Min/Max Average bps In/Out chart 

• Percent Utilization chart 

• Total Bytes Transferred chart 

Note: Optimize the ability of charts to display longer time periods by clicking Edit 
in the resource header to customize each chart as you require. 

Orion NPM also provides reports that can help you recognize trends and 
bottlenecks at the interface level on your network. The following interface-level, 
Historical Traffic reports, available by clicking Reports in the Views toolbar, track 
interface trends: 

• Average and Peak Traffic Rates – Last 7 Day 

• Average and Peak Traffic Rates – Last Month 
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• Average and Peak Traffic Rates – This Month 

• Average and Peak Traffic Rates – Wan Interfaces Last 7 Days 

• Total Bytes Transferred by Interface – Last Month 

• Total Bytes Transferred by Interface – This Month 

Viewing Useful Volume Capacity Resources 
The Orion Web Console provides many useful resources that can help you 
recognize trends and problems at the volume level. The following volume-level 
charts are available as resources within Orion Web Console views: 

• Average Disk Space Used chart -- customized to display longer time periods 

• Percent Disk Space Used chart – customized to display longer time periods 

Orion NPM also provides Historical Volume Usage reports that can help you 
recognize trends and problems at the volume level on your network. Historical 
Volume Usage reports are available by clicking Reports in the Views toolbar. 
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Appendix A 

Software License Key 

During installation, you may be prompted with the Install Software License Key 
window requesting that you supply your name, e-mail address, phone number, 
customer ID, and password. If this is the case, follow the instructions below to 
enable a software license key. 

To enable a software license key: 

1. If the computer on which you are installing Orion Network Performance 
Monitor is connected to the Internet, enter the requested information on 
the Install Software License Key window, and then click Continue. 

Note: The SolarWinds license registration server will immediately issue a 
license key that will allow Orion NPM to operate. 

2. If the computer on which you are installing Orion NPM is not connected 
to the Internet, your server cannot authenticate to the SolarWinds license 
registration server, so you must complete the following procedure: 

a. Click Skip This and Enter Software License Key Now on the Install 
Software License Key window. 

b. Using another computer that is connected to the Internet, log in to the 
customer area of the SolarWinds website at www.solarwinds.com/keys. 

c. Click Software Keys from the Customer Area menu. 

d. Select the product for which you need a key, and follow the instructions 
on the page to obtain a key. 

e. Enter the key in the Enter Software License Key text box. 

3. Click Continue to complete your Software License Key installation. 
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